0

I'm trying to configure Dovecot to access mysql, but it's not working because there is a space in the mysql password.

driver = mysql
connect = "host=localhost dbname=postfix user=postfix password=blah bluh blih"

When I'm trying to access a mailbox from Thunderbird / Evoution, I'm getting this error :

Jan 05 14:41:11 mx1 dovecot[28895]: auth: Fatal: mysql: Missing value in connect string: bluh

I can't find the proper syntax to make it work. Has someone an idea ?

  • 1
    Try: connect = 'host=localhost dbname=postfix user=postfix password="blah bluh blih"' – Raman Sailopal Jan 5 '18 at 13:51
  • Unfortunately, neither connect = 'host=localhost dbname=postfix user=postfix password="blah bluh blih"' or connect = "host=localhost dbname=postfix user=postfix password='blah bluh blih'" are working. – Sanael Jan 5 '18 at 13:56
  • 2
    I advise not using spaces in DB passwords. How about " ... password=\"blah blah\" "? – Rui F Ribeiro Jan 5 '18 at 13:58
  • 2
    Another option maybe connect = 'host=localhost dbname=postfix user=postfix password="blah\ bluh\ blih" although as Rui is right in saying that spaces in passwords is not advised. – Raman Sailopal Jan 5 '18 at 13:59
  • It's not working either. I guess I need to change the password now. Thanks for the help though. – Sanael Jan 5 '18 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.