-1

I'm using a 2.7T Porsche Design Desktop Drive (external HDD) at work and I need to mount it on a Proxmox 4.4-13 server. Currently I have several personal info but also have around 1TB free and the Proxmox server is running out of space. So after plug-in the disk to the server and execute fdisk -l the output is:

Device     Boot Start       End   Sectors  Size Id Type
/dev/sdc1  *       63 732566645 732566583  2.7T  7 HPFS/NTFS/exFAT

And the output for blkid is:

/dev/sdc1: LABEL="linux" UUID="2AB890F5B890C12D" TYPE="ntfs"

So far Proxmox is listing the external device with the identifier sdc1. Now I need to create a mount point for the external HDD. I won't use /mnt/ because Proxmox has some relevant info already there. The directory will be created at /home/ and the name will be mountpoint so:

mkdir mountpoint

The next steps show the process of mounting the device (mount) with rw permission, entering the mountpoint file (cd) and listing the files within (ls)

root@pve02:/home# mount -o rw /dev/sdc1 /home/mountpoint/
root@pve02:/home# cd mountpoint/
root@pve02:/home/mountpoint# ls
admin.jpg BackupsELEKA Pedro $RECYCLE.BIN System Volume Information
root@pve02:/home/mountpoint#

As the picture describes, the mount process was good, the ls command lists all the folder inside the external HDD. However when I try to create a folder (mkdir) or even create a file (touch) I got this:

root@pve02:/home/mountpoint# mkdir test
mkdir: cannot create directory ‘test’: Read-only file system
root@pve02:/home/mountpoint#

Then WHY? Didn't the option rw specify to allow read and write on the external disk? I have to say I tried to create folder and files inside a folder (Pedro and BackupsELEKA) and still nothing.

The thing is this should be a simple process to achieve, not a big deal, just like any other OS could do, why so difficult?

I'm posting this question after reading several posts such as: https://askubuntu.com/questions/333287/external-hard-disk-read-only and https://askubuntu.com/questions/47538/how-to-make-read-only-file-system-writable

  • Don't post screenshots of text, paste the actual text. – jasonwryan Jan 4 '18 at 21:14
  • I don't get why that could be a reason to downvote the post, still I will put the actual text. – Ophion Jan 4 '18 at 21:18
0

it's an ntfs filesystem , so you must pass the right type of filesystem to the mount command

mount -t ntfs-3g /dev/sdc1 /home/mountpoint/
  • You should explain there is a performance impact to using that and why his original command didn't work. – jdwolf Jan 4 '18 at 21:23
  • After running that command I get: mount: unknown filesystem type 'ntfs-3g' – Ophion Jan 4 '18 at 21:25
  • Looks like I don't have ntfs-3g installed, going out from work, will feed tomorrow the result after installing ntfs-3g – Ophion Jan 4 '18 at 21:30
  • you don't have the ntfs-3g package already installed on your system. – D'Arcy Nader Jan 4 '18 at 21:31
  • I updated repositories then did apt-get install ntfs-3g. Finally mount -t ntfs-3g /dev/sdc1 /home/mountpoint as @D'ArcyNader suggested and now I can create directories inside the external drive. – Ophion Jan 5 '18 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.