1

I have added a repository to sources list for a package from a newer Ubuntu version. Then I apt-get installed the package, with a number of other required packages. This broke the package system: I am unable to install updates or run Kate, for example. How to fix it?

Below is the output of apt-get -f install.

root@k2:/etc/apt/sources.list.d# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.5 LTS
Release:    14.04
Codename:   trusty

root@k2:/etc/apt/sources.list.d# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
kaddressbook : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
kde-telepathy-contact-list : Depends: kdepim-runtime but it is not installed
kdegraphics-strigi-analyzer : Depends: libstreamanalyzer0 (>= 0.7.8) but it is not installed
kdepim-kresources : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
                    Recommends: korganizer but it is not installed
kmail : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
knotes : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
kontact : Depends: kdepim-runtime but it is not installed
        Recommends: korganizer but it is not installed
libalgorithm-diff-xs-perl : Depends: perlapi-5.18.1
libapparmor-perl : Depends: perlapi-5.18.2
libapt-pkg-perl : Depends: perlapi-5.18.1
libarchive13 : Depends: libnettle4 (>= 2.3) but it is not installed
libc-bin : Depends: libc6 (> 2.23) but 2.19-0ubuntu6.13 is installed
libc-dev-bin : Depends: libc6 (> 2.23) but 2.19-0ubuntu6.13 is installed
libc6-dbg : Depends: libc6 (= 2.23-0ubuntu3) but 2.19-0ubuntu6.13 is installed
libc6-dev : Depends: libc6 (= 2.23-0ubuntu3) but 2.19-0ubuntu6.13 is installed
libc6-i386 : Depends: libc6 (= 2.23-0ubuntu3) but 2.19-0ubuntu6.13 is installed
libcairo-perl : Depends: perlapi-5.18.1
libcalendarsupport4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libclone-perl : Depends: perlapi-5.18.1
libcommon-sense-perl : Depends: perl (< 5.18.3~) but 5.22.1-9 is installed
libcupscgi1 : Depends: libcups2 (= 1.7.2-0ubuntu1.8) but 2.1.3-4 is installed
libcupsimage2 : Depends: libcups2 (= 1.7.2-0ubuntu1.8) but 2.1.3-4 is installed
libcupsmime1 : Depends: libcups2 (= 1.7.2-0ubuntu1.8) but 2.1.3-4 is installed
libcupsppdc1 : Depends: libcups2 (= 1.7.2-0ubuntu1.8) but 2.1.3-4 is installed
libdbd-mysql-perl : Depends: perlapi-5.18.2
libdbi-perl : Depends: perlapi-5.18.1
libdigest-crc-perl : Depends: perlapi-5.18.1
libeventviews4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libfile-fcntllock-perl : Depends: perlapi-5.18.1
libglib-perl : Depends: perlapi-5.18.1
libgmp-dev : Depends: libgmp10 (= 2:5.1.3+dfsg-1ubuntu1) but 2:6.1.0+dfsg-2 is installed
libgnutls28 : Depends: libhogweed2 (>= 2.7) but it is not installed
            Depends: libnettle4 (>= 2.7) but it is not installed
libgstreamer-perl : Depends: perlapi-5.18.1
libgtk2-notify-perl : Depends: perlapi-5.18.1
libgtk2-perl : Depends: perlapi-5.18.2
libgtk2-trayicon-perl : Depends: perlapi-5.18.1
libhtml-parser-perl : Depends: perlapi-5.18.1
libidn11-dev : Depends: libidn11 (= 1.28-1ubuntu2.2) but 1.32-3ubuntu1 is installed
libincidenceeditorsng4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libio-pty-perl : Depends: perlapi-5.18.1
libjson-xs-perl : Depends: perlapi-5.18.1
libkdepim4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libkdepimdbusinterfaces4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libkio5 : Depends: libstreamanalyzer0 (>= 0.7.8) but it is not installed
libkpeople3 : Depends: kdepim-runtime but it is not installed
libksieveui4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libktpcommoninternalsprivate7 : Depends: kdepim-runtime but it is not installed
liblist-moreutils-perl : Depends: perlapi-5.18.1
liblocale-gettext-perl : PreDepends: perlapi-5.18.1
libmailcommon4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libmailimporter4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libmessagecomposer4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libmessagecore4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libmessagelist4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libmessageviewer4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libncurses5-dev : Depends: libtinfo5 (= 5.9+20140118-1ubuntu1) but 6.0+20160213-1ubuntu1 is installed
                Depends: libncurses5 (= 5.9+20140118-1ubuntu1) but 6.0+20160213-1ubuntu1 is installed
libnet-dbus-perl : Depends: perlapi-5.18.1
libnet-dns-perl : Depends: perlapi-5.18.1
libnet-libidn-perl : Depends: perlapi-5.18.1
libnet-ssleay-perl : Depends: perlapi-5.18.2
libnoteshared4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libp11-kit-dev : Depends: libp11-kit0 (= 0.20.2-2ubuntu2) but 0.23.2-3 is installed
libpango-perl : Depends: perlapi-5.18.1
libperl5.18 : Depends: perl-base (= 5.18.2-2ubuntu1.3) but 5.22.1-9 is installed
libperlio-gzip-perl : Depends: perlapi-5.18.1
libpimactivity4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libpimcommon4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libpurple0 : Depends: perlapi-5.18.2
libreoffice-calc : Depends: libc6 (>= 2.23) but 2.19-0ubuntu6.13 is installed
libreoffice-math : Depends: libreoffice-core (= 1:4.2.8-0ubuntu5.2) but 1:5.1.2-0ubuntu1 is installed
librtmp1 : Depends: libhogweed2 but it is not installed
            Depends: libnettle4 but it is not installed
libsocket6-perl : Depends: perlapi-5.18.2
libsub-identify-perl : Depends: perlapi-5.18.1
libsub-name-perl : Depends: perlapi-5.18.1
libtasn1-6-dev : Depends: libtasn1-6 (= 3.4-3ubuntu0.5) but 4.7-3 is installed
libtemplateparser4 : Depends: kdepim-runtime (>= 4:4.10.2) but it is not installed
libterm-readkey-perl : Depends: perlapi-5.18.1
libtext-charwidth-perl : Depends: perlapi-5.18.1
libtext-iconv-perl : Depends: perlapi-5.18.1
libtext-soundex-perl : Depends: perlapi-5.18.1
libtinfo-dev : Depends: libtinfo5 (= 5.9+20140118-1ubuntu1) but 6.0+20160213-1ubuntu1 is installed
libuuid-perl : Depends: perlapi-5.18.1
libxml-libxml-perl : Depends: perlapi-5.18.2
libxml-parser-perl : Depends: perlapi-5.18.1
nettle-dev : Depends: libnettle4 (= 2.7.1-1ubuntu0.2) but it is not installed
            Depends: libhogweed2 (= 2.7.1-1ubuntu0.2) but it is not installed
p11-kit-modules : Depends: libp11-kit0 (= 0.20.2-2ubuntu2) but 0.23.2-3 is installed
pidgin : Depends: perlapi-5.18.2
plasma-dataengines-workspace : Depends: kdepim-runtime but it is not installed
plasma-widgets-workspace : Depends: kdepim-runtime but it is not installed
python-kde4 : Depends: kdepim-runtime but it is not installed
python3-pykde4 : Depends: kdepim-runtime but it is not installed
python3-uno : Depends: libreoffice-core (= 1:4.2.8-0ubuntu5.2) but 1:5.1.2-0ubuntu1 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
  • Disable the added repository which cause the problem then try to fix apt : apt-get update , apt-get -f install – GAD3R Jan 4 '18 at 14:59
  • @GAD3R Doesn't work. – Nucular Jan 5 '18 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.