3

I have an headless system running Ubuntu 14, with a xtion pro live camera connected to do some live video elaboration. Sometimes on boot (every morning is power on, but this is happening ramdomly) the camera is not recognized and dmesg shows:

usb 1-2: device descriptor read/8, error -110 usb usb1-port2: unable to enumerate USB device

The camera is not even listed in lsusb. What I tried without any success is:

The only working solution is to poweroff/poweron the computer (not feasible as is an headless system, it poweroff every night, and poweron every morning but I'd avoid waiting next day when the problem occurs). Is there any solution to simulate the physical disconnection of the device (I not even sure if this would work) or the poweroff for what USB concerns? Any ideas will be appreciated, thank you.

7
  • Here you might find your solution: stackoverflow.com/questions/4702216/…
    – Petr
    Jan 4, 2018 at 10:58
  • it doens't work
    – rok
    Jan 4, 2018 at 11:31
  • Try uhubctl -R -a cycle. But it will work only if your hub supports per port power switching (to be recognized by uhubctl).
    – mvp
    Jan 21, 2018 at 7:45
  • it's already in the attempts list without any success..
    – rok
    Jan 24, 2018 at 14:02
  • @rok: did you try with -R? Adding -R will try to use appropriate USB reset mechanism supported by your OS (Linux in this case).
    – mvp
    Feb 2, 2018 at 0:28

1 Answer 1

1

First, check whether the device port is USB 2.0 or USB 3.0 -

$ lspci | grep USB
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)

Then, to elevate to root:

$ sudo -i

If the port is USB 3.0:

# ls  /sys/bus/pci/drivers/xhci_hcd/
0000:00:14.0 bind  new_id  remove_id  uevent  unbind
# echo -n "0000:00:14.0" | tee /sys/bus/pci/drivers/xhci_hcd/unbind
# echo -n "0000:00:14.0" | tee /sys/bus/pci/drivers/xhci_hcd/bind

If the port is USB 2.0:

# ls  /sys/bus/pci/drivers/ehci-pci/
0000:00:14.0 bind  new_id  remove_id  uevent  unbind
# echo -n "0000:00:14.0" | tee /sys/bus/pci/drivers/ehci-pci/unbind
# echo -n "0000:00:14.0" | tee /sys/bus/pci/drivers/ehci-pci/bind
2
  • as I said.. I already tried this method without any luck..
    – rok
    Oct 10, 2020 at 16:59
  • yes @RomanRiabenko You are right, it was there in my output as well. it was a typo. fixed it now!!
    – Nir_punIN
    Oct 15, 2020 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.