1

I have installed mail server with postfix and dovecot.
My clients use The Bat email client software.
While sending mails, they use tcp port 587 with STARTTLS.
And I disabled tcp port 25 for sending mails in firewall (in server).

Now, they receive mails via tcp port 110 POP3 protocol.
I want to use IMAP or IMAPS for receiving mails for my clients.
And I totally want to disable POP3 protocol.

1) I tried to change port number to 143 for receiving mails in "The Bat", but it cannot receive mails. How can I do it right?
2) Should I reconfigure dovecot for using IMAP/S only?
3) Is my idea is right?

PS: I opened port 143 on my server in firewall.

  • Please link to your previous question if they are related: unix.stackexchange.com/questions/414476/… – Weijun Zhou Jan 4 '18 at 5:32
  • There wasn't told about IMAP/IMAPS and switching from POP3 to IMAP – it dev Jan 4 '18 at 5:39
  • Well... it should work like a charm with proper configuration. So you must have a misconfiguration between postfix and dovecot. – Petr Jan 4 '18 at 11:19
0

Make sure your dovecot configuration is done right. (how to)

  1. Depending on a version check if you have imap protocol enabled in:
    /etc/dovecot.conf
    /etc/dovecot/dovecot.conf
    OR
    /etc/dovecot/conf.d/10-master.conf

  2. Than check if dovecot is listening on 143

  3. Than check it from outside, that the port is really opened.

  4. Setup the client (how to)

EDIT: Issue was solved, problem was on clients side (Bat email client)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.