3

I have a fresh new install of Ubuntu Server 16.04. After installation, network connectivity was fine.

I installed QuickBox, it's a seeding/torrent server software (https://quickbox.io).

After the installation it was still fine; I could SSH in and out no problem. The installation however recommended I restart the server for some files to finish installation.

After restarting the server I lost all network connectivity; I continued getting the error:

RTNETLINK answers: File Exists
Failed to bring up eno1

The interfaces file looked fine, had the correct networking information. No duplicate gateways were set in interfaces configuration either.

I ran the following command to get some feedback and got this:

sudo ifdown eno1 && sudo ifup -v eno1
ifdown: interface eno1 not configured
configuring interface eno1=eno1 (inet)
/bin/run-parts --exit-on-error --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/ethtool
run-parts: executing /etc/network/if-pre-up.d/ifenslave
* [ inet = meta ]
* IF_BOND_SLAVES=
* []
* []
* [ -z ]
*exit
run-parts: executing /etc/network/if-pre-up.d/vlan
/bin/ip addr add 216.176.200.X/255.255.255.X broadcast 216.176.200.X
RTNETLINK answers: File exists
Failed to bring up eno1.

I tried flushing the device as well that didn't work. I tried restart networking service, still fails. There are no extra configs in interfaces.d directory.

My interfaces file looks like this:

iface eno1 inet static
       address 216.176.200.X
       netmask 255.255.255.X
       network 216.176.200.X
       broadcast 216.176.200.X
       gateway 216.176.200.X
       # dns-* options are implemented by the resolvconf package, if installed
       dns-nameservers 209.151.232.X 209.151.224.X
       dns-search domain.xyz

Also, when I do a "route -n" nothing comes up in the kernel routing table, its just completely blank.

Same thing when I run a "netstat -rn"; the routing table is completely blank.

Is it the routing table? I tried adding the routing info manually but I still got the same error.

I flushed the device as well and tried again and that didn't work either.

What is this RTNETLINK? I googled around and tried all the previous solutions people posted but none of them worked and still couldn't find a straight answer as to what this file is.

  • If you are not too fond of /etc/network/if-pre-up.d/vlan you should maybe move it to /root – Ralph Rönnquist Jan 4 '18 at 12:20
  • @RalphRönnquist is that directory/file what is causing the network error? – Pietro Aretino Jan 4 '18 at 22:04
  • From the log output it looks like that vlan script tries to set an ip address (with bad syntax), and it fails, causing the whole thing to fail. – Ralph Rönnquist Jan 5 '18 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.