6

I am writing this question since I had no problem in years of using OpenCL with nVidia graphics in fedora and testing Darktable with it. But now in Fedora 27 I am trying to use Darktable with Intel Graphics opencl capability but when I do darktable -d opencl I get this response as it doesn't recognize:

Beignet: self-test failed: (3, 7, 5) + (5, 7, 3) returned (6, 7, 5)

and when I do clifo it winds three devices. I thought it should find only two, my CPU and my GPU. My CPU is Intel Core i7-7500U and that's it.

I have installed these packages: ocl-icd, opencl-filesystem, opencl-utils-devel and beignet. I think these cover all the necessary dependencies.

The question is: Is it possible to use Darktable's opencl capability with this GPU or not? and how can I do it using beignet and Fedora 27?

2 Answers 2

0

This is a known bug with __local memory on beignet, see if this workaround works for you:

export OCL_IGNORE_SELF_TEST=1 
1
  • Thanks for the response, but unfortunately It doesn't fix the problem. Although it seems like the solution, I get the response which says: Intel(R) HD Graphics Kabylake ULT GT2' because the driver `OpenCL 2.0 beignet 1.3' is blacklisted.
    – M.Rez
    Commented Jan 25, 2018 at 16:16
0

Beignet is blacklisted in darktable. You could try to remove it from the list and recompile darktable and see if it works: https://github.com/darktable-org/darktable/blob/master/src/common/opencl_drivers_blacklist.h Line 27. Darktable devs have disabled Beignet because they see not much gain in using intel cards with opencl. You can read more about it here: https://www.darktable.org/2012/03/darktable-and-opencl/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .