0

I had Linux Mint on dualboot, but I was having problems with the audio, so I deleted the partition using disk manager on windows 10, and was going to install Debian, but when I try to boot Debian from the usb, it goes to GRUB and I am unable to get past this. I tried many solutions on various forums and none of them have removed this obstacle. Anyone got any ideas?

  • You mean the bios doesn't let you interrupt boot to access boot media priority menu ? Or you can boot but on disk instead of USB ? (then your usb stick is not bootable so it ignore it & go back to normal boot on disk)) – francois P Jan 3 '18 at 22:27
  • I am able to get into the bios, and even the boot media priority. When I change the boot order to load from a device, it goes to a grub screen. – Daniel Horn Jan 3 '18 at 22:28
  • so I think your usb stick is not bootable did you build it from a gerrator-tool or by yourself just copying iso on it ? a method to build USB bootable stick is doing a dd if=debianxx.iso of=/dev/somedevicename bs=4M && sync did you remember having done something similar ? – francois P Jan 3 '18 at 22:30
  • I used unetbootin to build it. – Daniel Horn Jan 3 '18 at 22:31
  • [link]imgur.com/gallery/fuTYt – Daniel Horn Jan 3 '18 at 22:34
0

If your computer supports UEFI boot, you should be able to boot directly from the flash drive (reference your motherboard's keyboard shortcuts for the exact boot key). Otherwise, you'll need a direct-write utility to write the ISO to the flash drive. Unetbootin is old software and not necessary when you have a bootable ISO (most are these days).

  • UNetbootin is updated regularly. – jdwolf Jan 4 '18 at 2:41
  • Thanks for the correction. To clarify, unetbootin was conceived before Linux ISOs were created with USB boot in mind. From what I hear, it tends to modify the image which can cause booting issues. I'd recommend using a different program to wrote the image. – Free Bullets Jan 4 '18 at 6:33
0

As @jdwolf already commented...

You may actually be booting from USB after all. If the system is booting in UEFI mode, there should be an UEFI bootloader at \EFI\boot\bootx64.efi on the USB stick. On Linux installation media, this UEFI bootloader is often an UEFI version of GRUB.

If unetbootin changed the layout of the boot files without also adjusting the configuration of the UEFI bootloader (which might be found at \EFI\boot\bootx64.cfg or \EFI\boot\grub.cfg), then your boot attempt from the USB media might end up with an UEFI GRUB with no valid configuration.

It is also possible that your UEFI implementation may be buggy. Some UEFI versions of GRUB were quite sensitive to UEFI implementation details - I think this has been improving lately, as the GRUB developers receive bug reports and other experience on various UEFI implementations.

With modern distributions, unetbootin and similar tools could be unnecessary for preparing an installation USB media: many installation ISOs come now prepared with isohybrid (see here) or similar tools so that you can simply write the ISO to the USB media using dd or a similar tool and have it just work. This way both the legacy BIOS and UEFI bootloaders on the installation media should be using the configuration that the distribution maintainers have actually tested, rather than a configuration built by unetbootin using heuristics.

0

As a last resort you can try to enable "legacy boot" option if supported by you BIOS.

In my previous experience (hp envy 15 amd apu), the bootable flash drive (gentoo x86_64) required this option in order to be detected by the bios.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.