0

I am running Debian 9 via Crouton on an Intel Chromebook. I've had some difficulties with bash and the display, however I resolved these. I installed Steam, and the games work on it, however I only have 16GB on the eMMC chip inside the computer.

I would like to download Steam games on an external SD card. Inside the Chroot, the SD card I have inside the built in slot is mounted in /media which has a symbolic link to /var/host/media/removable/USB (USB being the name of the SD card), however when I try to add it as an extra Steam games location, Steam tells me that the "new Steam library folder must be on a filesystem with execute permissions".

Just to be clear, I am able to read and modify contents on the SD card via the Chroot. How can I make the SD card usable by Steam?

  • What are the permissions of the directory on which the filesystem is mounted? Does the underlying directory have +x? – EightBitTony Jan 3 '18 at 18:21
  • i dont know, when i launch crouton, the directory is automatically mounted – user77647 Jan 3 '18 at 20:48
2

Your SD card is mounted with the noexec option (or perhaps user, which includes noexec). You need to remount it with the exec option explicitly; you might find it easiest to add an entry to /etc/fstab with the appropriate options (user,exec should do the trick).

  • My fstab file is empty, it just says # unconfigured – user77647 Jan 3 '18 at 20:55
  • 1
    Yes, which is why I said you'd have to add an entry. See also issue 3579 re the empty /etc/fstab. – Stephen Kitt Jan 3 '18 at 22:38
  • i ended up opening gnome-disks using gksudo (doing it without root gave me the quark 4 error), disabled automatic mounting options which revealed fixed options within fstab, and added users(with the s) and exec, and only this way it worked. your answer is correct, but i wanted to mention these details as well – user77647 Jan 4 '18 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy