0

I am installing Debian stretch 9.3 from a USB stick and I am getting a DHCP configuration error cannot configure dhcp automatically

I tried using : direct cable to the router LAN & a wireless adapter TP-LINK but both results the same error.

alt + f4 tty gives the following error:

Soliciting ff02::2 (ff02::2) on enp0s3...
Timed out.
No response.

Sending discover ........
Sending select for 192.168.1.3 ....
udhcp: has been called with an unknown param lease fail

Any suggestion or help would be very appreciated. Thanks !

  • 1
    if you are not experienced it might be easier starting with the DVD1 image than the netinst image. netinst wont support all the hardware you throw at it. – Rui F Ribeiro Jan 2 '18 at 18:40
  • 1
    @Rui what hardware have you encountered that’s supported by DVD1 but not netinst? I wouldn’t have thought there would be any difference (unlike netinst+firmware), apart from the fact that the network isn’t necessary to install off DVD1... – Stephen Kitt Jan 2 '18 at 19:44
  • 1
    @StephenKitt Too long ago to remember I am afraid - I think they were HP or Dell servers. But yeah, namely DVD1 allows you to install stuff without still having a network connection. I have not installed Debian from scratch for quite a while now I am afraid. – Rui F Ribeiro Jan 2 '18 at 19:48
  • 1
    @Lotfio, if you press Alt+F4 after DHCP fails, you'll get more detailed information about what went wrong; could you try again and see if there's anything relevant there? – Stephen Kitt Jan 2 '18 at 22:40
  • 1
    @Rui that sounds like tg3 or Broadcom Ethernet requiring firmware, if my experience with HP and Dell hardware from a few years ago is anything to go by :-/. – Stephen Kitt Jan 2 '18 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.