5

I had a Hadoop version 1.x installed on Linux SUSE 12.3. I moved the directory somewhere else to back it up. I tried to install Hadoop 3.0. I expect Hadoop commands to work based on what I did. I used open source Hadoop 3.0 files. Hadoop commands do not work (with or without sudo).

I have set $HADOOP_COMMON_HOME to be both of these values but the problem kept happening:

$HADOOP_PREFIX

/usr/local/hadoop/hadoop-yarn-project/hadoop-yarn

Neither worked. Whenever I run a Hadoop command I get an error. If I run this command:

sudo /usr/local/hadoop/hadoop-common-project/hadoop-common/src/main/bin/hadoop version

I get this error:

ERROR: Invalid HADOOP_COMMON_HOME

How do I get Hadoop commands to work?

2
  • kindly provide me with the output of protoc --version Dec 31, 2017 at 22:32
  • Here is the output: If 'protoc' is not a typo you can use command-not-found to lookup the package that contains it, like this: cnf protoc The only file with the name "protoc" was a directory named "protoc" in a hadoop-maven-plugins directory.
    – Jermoe
    Jan 1, 2018 at 1:26

0

You must log in to answer this question.

Browse other questions tagged .