1

Under my new Linux Mint 18.3 (64 bit) installation on my notebook, the command

$ sudo apparmor_status

returns the following:

apparmor module is loaded.
apparmor filesystem is not mounted.

Is AppArmor configured for usage under Linux Mint or do I have to enable and configure it first? Because, as you can see, the command does not return a list of active AppArmor profiles.

3

To enable apparmor you need to boot your system with apparmor=1 security=apparmor option.

Edit your /etc/default/grub by modifying the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

To:

GRUB_CMDLINE_LINUX_DEFAULT="apparmor=1 security=apparmor quiet"

Then update grub and reboot:

sudo update-grub
sudo reboot

Debian : Enable AppArmor

Enable the AppArmor LSM:

$ sudo mkdir /etc/default/grub.d
$ echo 'GRUB_CMDLINE_LINUX_DEFAULT="$GRUB_CMDLINE_LINUX_DEFAULT apparmor=1 security=apparmor"' \
  | sudo tee /etc/default/grub.d/apparmor.cfg
$ sudo update-grub
$ sudo reboot
2

First of all, you don't need to load anything special in linux mint 18 for apparmor to work, however only some of the apparmor packages are installed by default. After searching for apparmor in package manager, the only apparmor packages I do not install are the libapache-apparmor apparmor-dev packages(I don't have apache installed and don't need the development package..same as most users). You will probably want the same.

I suspect that is what the problem is. You can just use sudo aa-status by the way..

Hope that helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.