I recently installed Kali Linux on a spare laptop of mine to test my wifi's security. I checked the supported modes in a console to confirm monitor mode was supported using

iw list

And it indeed shows Monitor Mode in the list. I tried putting it into monitor mode using two different methods

airmon-ng start wlan0


ifconfig wlan0 down
iwconfig wlan0 mode monitor
ifconfig wlan0 up

Both ways worked, however whenever I monitor my access point using

airodump-ng --bssid MY:BS:ID wlan0mon

It shows my access point and the beacons steadily increase. However, I never see any devices show up even though I have plenty connected and have tried to disconnect and manually reconnect to try and force it to show with no luck.

I've made sure that promiscuous mode is also on using

ip link set wlan0 promisc on


Am I doing anything wrong?

How can I get devices to actually show up?

  • What channel does your access point operate on? By default, airodump-ng will cycle through all channels and may not capture everything that is occuring. Try forcing it to your channel with the -c flag. – multithr3at3d Jan 1 '18 at 0:26
  • Channel 1. I've tried setting it using -channel 1, but still no luck. Isn't -c for frequency? – CaffeinatedCoder Jan 1 '18 at 2:09
  • Did you airmon-ng check-kill before airmon-ng start wlan0? – bu5hman Jan 1 '18 at 11:06
  • Someone over at aircrack-ng.org had a very similar issue. Traced his issue to kernel/drivers. – bu5hman Jan 1 '18 at 11:15
  • Yes, I tried killing all troublesome processes. I'm using the ath5 driver. How can I tell if it's a kernel issue? – CaffeinatedCoder Jan 1 '18 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.