0

During installation on my USB unfittingly I start installation on my own disk and the partition tables of LVM are replaced.

I have 3 partitions and they are replced identically. I can mount boot partition and get data with UUID from grub.cfg but I don't have a backup of LVM from etc

I tried vgcreate --UUID from grub but doesn't work. Also, tried testdisk but doesn't work.

Can someone explain me is there any way to recover creating with the same UUID from group with vgcreate from begging or some kind of mount data to recovery?

  • Has your system been running since this has happened or have you rebooted it / shut it down? – Hauke Laging Dec 30 '17 at 17:18
  • The system is turned off. No access to system after partition table has been changed – user3307783 Jan 13 '18 at 11:44
0

Consider LVM like another way to partition, but not with classic MBR.

give results of those commands :

sudo vgdisplay ; sudo pvdisplay ; sudo lvdisplay

if you're lucky this is all here you will just have to activate all of partitions (PV) rebuild VG & LV & mount them again.

  • Yes, I can active the current (last) created. But, they don't have ext4 filesystem and its request to format. Because when I try to mount the error is the wrong FS. – user3307783 Dec 30 '17 at 10:30
  • I think then, you just can't retrieve your datas – francois P Dec 30 '17 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.