3

How can I force pcmanfm to refresh its thumbnails. I have a directory of photos in JPG format, (taken with iphone). I have rotated some of these using Ubuntu Image Viewer. When I rotate the image the thumbnail does not update. How can I force it to update?

I have tried deleting all thumbnails form ~/.cache/thumbnails and selecting "reload folder" in pcmanfm but no joy. Any suggestions? Where are the thumbnails actually stored?

Using pcmanfm 1.2.4 on Ubuntu 16.04.

1
  • Also tried deleting cached thumbnails from ~/.thumbnails also didn't work.
    – Ron
    Dec 29, 2017 at 16:19

3 Answers 3

0

The problem may not be on pcmanfm. If you take pictures with your mobile device, then it's likely the JPEG file contains a thumbnail in itself (See Exif). pcmanfm simply uses that one as the thumbnail and display it.

However, when you rotate your image on your desktop, it's likely the image editing software updates the image itself but not its thumbnail. Therefore it creates discrepancy between the image and its thumbnail.

To confirm this, you can use exiv2 to detect whether there's a thumbnail in the JPEG file:

exiv2 image.jpg | grep -i thumbnail

If so, you can extract it to see if it matches the image itself:

exiv2 -et image.jpg

Finally, you can delete the thumbnail in the JPEG file:

exiv2 -dt image.jpg

Open pcmanfm again and see if it handles thumbnails correctly.

If you really want to keep the thumbnail in the JPEG file, you can look for a photo editing software that correctly updates thumbnail. But personally I feel it quite good not to have it as this can save some space if you have a lot of pictures.

3
  • 1
    How can I force pcmanfm to ignore the EXIF thumbnail? I don't want to touch the file itself...
    – Michael
    Mar 28, 2019 at 4:07
  • @Michael Open a ticket on its issue tracker!
    – Cyker
    Mar 28, 2019 at 23:35
  • that's too much work... i just implemented a new API which multiplexes between the thumbnail, creating it if it doesn't exist, and the built-in EXIF thumbnail, if it's there.
    – Michael
    Mar 29, 2019 at 0:08
0

Go to Edit Preferences in the Menu Bar. A dialog will open up. Make sure show thumbnails is checked and if you saw some thumbnails in this program, it will be. Where it says "do not generate thumbnails for images exceeding this size", change the number to a number that is as large as you dare.

You might want to uncheck "only generate thumbnails for local files", if you want to be able to view thumbnails that are on your camera or phone.

0

Deleting everything in ~/.thumbnails worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .