I purchased a Seagate Backup Plus 5 TB USB 3.0 Portable 2.5" drive as I've recently maxed out the 1TB drive I have connected to my RPi2 running ArchLinuxARM and serving up music around the home (thanks to snapcast).

I've formtated the drive from the default Micro$oft with ext4 on my main desktop/server (running Gentoo) without any problem. I purposefully omitted reserving space for root on the device when doing so using the '-m 0' option...

mkfs.ext4 -m 0 /dev/sdg1

...and once complete used rsync to copy all my ripped music and video to the Seagate drive before plugging it into the RPi2.

The RPi2 detects the device and purports to mount it but I can not read anything from it nor is it detected by df...

dmesg  | grep sdb -B5 -A5
[    6.818812] systemd[1]: Set hostname to <alarmpi>.
[    7.138564] uart-pl011 3f201000.serial: no DMA platform data
[    7.314785] systemd[1]: File /usr/lib/systemd/system/systemd-journald.service:35 configures an IP firewall (IPAddressDeny=any), but the local system does not support BPF/cgroup based firewalling.
[    7.340062] systemd[1]: Proceeding WITHOUT firewalling in effect! (This warning is only shown for the first loaded unit using IP firewalling.)
[    7.437703] scsi 1:0:0:0: Direct-Access     Seagate  BUP SL           0304 PQ: 0 ANSI: 6
[    7.454293] sd 1:0:0:0: [sdb] Spinning up disk...
[    7.775111] systemd[1]: Set up automount mnt-seagate\x2d5tb.automount.
[    7.787824] systemd[1]: Set up automount mnt-backup\x2dvideo.automount.
[    7.798924] systemd[1]: Reached target Remote File Systems.
[    7.809832] systemd[1]: Set up automount mnt-backup\x2dpics.automount.
[    7.821316] systemd[1]: Set up automount Arbitrary Executable File Formats File System Automount Point.
[    9.516523] .
[   10.556508] .
[   11.596497] .
[   12.636494] .
[   12.636861] ready
[   12.641384] sd 1:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
[   12.651628] sd 1:0:0:0: [sdb] 9767541167 512-byte logical blocks: (5.00 TB/4.55 TiB)
[   12.664365] sd 1:0:0:0: [sdb] 2048-byte physical blocks
[   12.737473] sd 1:0:0:0: [sdb] Write Protect is off
[   12.744906] sd 1:0:0:0: [sdb] Mode Sense: 4f 00 00 00
[   12.745512] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   12.761056] sd 1:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
[   12.863681]  sdb: sdb1
[   12.870411] sd 1:0:0:0: [sdb] Very big device. Trying to use READ CAPACITY(16).
[   12.881906] sd 1:0:0:0: [sdb] Attached SCSI disk
[   13.946160] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
[   13.957666] bcm2835-rng 3f104000.rng: hwrng registered
[   14.022165] snd-rpi-iqaudio-dac soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered - will retry
[   14.181087] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   14.190832] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   20.184910] wlan0: RX AssocResp from 00:25:9c:13:e7:12 (capab=0x431 status=0 aid=4)
[   20.301723] wlan0: associated
[   20.306827] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  110.045728] pcm512x 1-004c: No SCLK, using BCLK: -2
[  111.975428] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[ 1428.731832] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)
[ 9204.593083] pcm512x 1-004c: No SCLK, using BCLK: -2
[17467.143120] pcm512x 1-004c: No SCLK, using BCLK: -2
[17499.068650] pcm512x 1-004c: No SCLK, using BCLK: -2

I try to mount it (as root) and it purports to mount...

# mount -v -t auto /dev/sdb1 /mnt/seagate-5tb
mount: /dev/sdb1 mounted on /mnt/seagate-5tb.
 # dmesg | tail -n3
[17467.143120] pcm512x 1-004c: No SCLK, using BCLK: -2
[17499.068650] pcm512x 1-004c: No SCLK, using BCLK: -2
[180078.489600] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts: (null)

However the drive is not detected by df nor can I ls the device...

# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        15G  8.1G  5.5G  60% /
devtmpfs        464M     0  464M   0% /dev
tmpfs           469M     0  469M   0% /dev/shm
tmpfs           469M  468K  468M   1% /run
tmpfs           469M     0  469M   0% /sys/fs/cgroup
tmpfs           469M  4.0K  468M   1% /tmp
/dev/mmcblk0p1  100M   24M   77M  24% /boot
/dev/sda1       917G  867G  3.5G 100% /mnt/backup-music
tmpfs            94M     0   94M   0% /run/user/1001
 # ls /mnt/seagate-5tb/
ls: cannot access '/mnt/seagate-5tb/': No such device

The kernel seems to have detected the device ok and ext4 is supported I think as its listed in /proc/filesystems

# cat /proc/filesystems 
nodev   sysfs
nodev   rootfs
nodev   ramfs
nodev   bdev
nodev   proc
nodev   cpuset
nodev   cgroup
nodev   cgroup2
nodev   tmpfs
nodev   devtmpfs
nodev   configfs
nodev   debugfs
nodev   tracefs
nodev   securityfs
nodev   sockfs
nodev   bpf
nodev   pipefs
nodev   rpc_pipefs
nodev   devpts
nodev   nfs
nodev   nfs4
nodev   autofs
nodev   overlay
nodev   mqueue

...so I'm somewhat stumped as to why the device isn't mounting correctly and would be grateful for any suggestions/pointers to investigate or try.

EDIT : Additional information on /etc/fstab

# more /etc/fstab
# <file system> <dir>   <type>  <options>   <dump>  <pass>
/dev/mmcblk0p1  /boot   vfat    defaults        0       0

# External drives
/dev/disk/by-label/backup-music    /mnt/backup-music    auto    auto,nofail,x-systemd.automount,users   0 0
/dev/disk/by-label/seagate-5tb     /mnt/seagate-5tb     auto    auto,nofail,x-systemd.automount,users   0 0

The device is present and the label definitely exists and points to the correct block device...

 # ls -l /dev/disk/by-label/
total 0
lrwxrwxrwx 1 root root 10 Dec 21 12:31 backup-music -> ../../sda1
lrwxrwxrwx 1 root root 10 Dec 21 12:31 seagate-5tb -> ../../sdb1

EDIT 2 : More information on partition table

Checked the partition table with fdisk and its GPT so the constraint of DOS should not be an issue here...

# fdisk  -l /dev/sdb
Disk /dev/sdb: 4.6 TiB, 5000981077504 bytes, 9767541167 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: EDF7F3CD-E4AF-4422-8015-31C1447BBB64

Device     Start        End    Sectors  Size Type
/dev/sdb1   2048 9767541133 9767539086  4.6T Linux filesystem
  • 1
    I see you have a partition table on the drive. Did you use DOS or GPT partitioning? The DOS partition table does not support over 2 TB disks. Dec 29, 2017 at 8:40
  • I used cfdisk to delete both pre-formatted partitions that were on the drive, a reserved M$ partition of about 128Mb and the remaining ~5TB. I then created a new primary ext4 partition across the whole drive and did not consciously or knowingly create a partition table (unless cfdisk did so in the background). Not adverse to formatting it again, but the drive mounts fine on my Gentoo system that I did the formatting on, just doesn't mount (despite being detected) on the Raspberry Pi (running Arch Linux ARM).
    – slackline
    Dec 29, 2017 at 8:48
  • Note that sdb1 already gets mount at [ 1428.731832], so maybe you are mounting it twice? Does the list you get with mount directly after boot contain sdb1, and to which directory is it mounted?
    – dirkt
    Dec 29, 2017 at 8:50
  • Yes, I'd seen that and its because I've written an entry into /etc/fstab but the drive isn't listed by either ls nor df on boot, and attempting to manually mount after booting doesn't work either. The entry in /etc/fstab has been added to the original post, it should mount to /mnt/seagate-5tb based on the disk label (which is correct and exists).
    – slackline
    Dec 29, 2017 at 9:08
  • @JohanMyréen checked the partition table using fdisk its GPT so the DOS limitation won't be an issue.
    – slackline
    Dec 29, 2017 at 16:38


You must log in to answer this question.

Browse other questions tagged .