0

I have multiple partitions on different disks along side my Linux installation, I have all the necessary packages installed for reading and writing to vfat filesystems.

main drive [SSD] my linux install. second drive [SSD] extra space for Linux, plus install for Windows 10 separate partition. third drive [External HDD], contains 2 partitions HFS+ and ExFAT.

I can't mount Windows or ExFAT partitions because mtab claims it's already mounted, but it's inaccessible. I checked mtab file, and there is no mounted entry for NTFS or ExFAT partitions.

Windows 10 labeled as W10 and ExFAT partition labeled as ExFAT.

[W10]

Error mounting /dev/sdb3 at /media/user/W10: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdb3" "/media/user/W10"' exited with non-zero exit status 21: mount: according to mtab, /dev/sdb3 is already mounted on /media/user/W10

[ExFAT]

Error mounting system-managed device /dev/sdc5: Command-line `mount "/media/user/ExFAT"' exited with non-zero exit status 1:
stdout: `FUSE exfat 1.0.1
'stderr: `mount: according to mtab, /dev/sdc5 is already mounted on /media/user/ExFAT'

I have never once changed the mounting options for these partitions, and I have tried unmounting the drives, but it says they're not mounted, even disconnected the external drive and still claims it's mounted by mtab after reconnecting when it's completely inaccessible. HFS+ partition on the external drive mounts just fine, I can browse that with no issues, just for some reason mounting NTFS and ExFAT partitions got messed up somehow. As far as I know for mounting Windows partitions you have to use vfat as the filesystem to be recognised, but ExFAT you can just use exfat when you just have exfat-utils and exfat-fuse installed just by doing sudo mount -t /dev/sdc5 /media/user/ExFAT. But in this current state I can't do that because mtab claims it's already mounted, and I just cannot access it anywhere, according to the gnome-disk-utility they're both set as Automatic Mount Options which worked just fine before.

0

Well, what is in your /etc/mtab file? Is there any reference to /dev/sdb3 or /dev/sdc5, no matter what filesystem?

The actual mount status information directly from the kernel is viewable at /proc/mounts: compare that to your mtab file.

Some distributions even link /etc/mtab to /proc/mounts: others have /etc/mtab as a regular file, since some user-space mounting tools may save some extra information in /etc/mtab.

The Linux partition type vfat is only for FAT and FAT32 filesystems, either with or without the VFAT extended file and directory names. Since Windows partitions can also be NTFS, "for mounting Windows partitions you have to use vfat" is not correct.

  • There is no link or reference of the mounted partitions within /proc/mounts and there's definitely as I've stated before does not show in /etc/mtab at all. – user91679 Dec 29 '17 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy