9

I just installed Ubuntu 16.04 LTS on my Lenovo Thinkpad P50s. Very quickly my mouse clicks stopped working. I can still click on the application launcher, but nowhere else. I’m totally new to Linux, so I have no idea how to start trying to fix this.

Update: Now my red dot isn’t working, and I can only move the move the mouse with the touchpad.

Update 2: Tried the unity --replace & solution and it did not work I plugged in a wired mouse that works When I do cat /proc/bus/input/devices/ the touchpad is not listed at all. I might add that the touchpad and trackpoint worked fine during the installation process. Could this be a hardware issue? I didn't think so at first because the computer has just been sitting here on my couch the whole time.

Update 3: Booted from the USB again and chose to try Ubuntu without installing and the mouse and touchpad work perfectly.

Going to try my luck reinstalling Ubuntu now

  • Did you ever figure this out? I have this same issue. I installed Ubuntu on an ASUS Zenbook, everything worked fine for a couple weeks. Then the trackpad and keyboard just stopped working. I can click on app icons to launch them, but once a window is open I can't click on anything or type. – Inn0vative1 Jun 21 '18 at 23:57
9

Try running this command in the terminal.

unity --replace &

If you're using the Compiz or Metacity window managers (which you are likely not, but if you're in this situation it will help), do this instead.

compiz --replace &

And for Metacity

metacity --replace &

It's very important you leave the & in there, so that the command is run in the background. If you CTRL-C or abort these commands while they're running, they could mess up your IO devices even more (for the session at least).

This thread on Superuser might help you. The original poster actually had a hardware problem, but there are a lot of answers that might work for you.

| improve this answer | |
  • I tried that and it did not work. when I run cat /proc/bus/input/devices/ I do not see the Synaptics touchpad listed at all – Christopher Heneghan Dec 28 '17 at 8:14
  • There's a touchpad disable button or key combo on some laptops. – RobotHumans Dec 28 '17 at 12:41
1

Running 16.04 on a Dell 5520 and 13 months after buying the laptop (factory installed Ubuntu) I had this issue. Tried the "unity --replace &" command, and it worked.

| improve this answer | |
1

Just Open the Terminal using Ctrl+ALt+T and type the following commands
modprobe -r psmouse Removes it
modprobe psmouse readds it

| improve this answer | |
  • 1
    This is unlikely to help as mouse movements are reported to work. – RalfFriedl Jun 2 '19 at 16:33
  • alright , yes it is working was an issue for some time – champion-runner Jul 21 '19 at 14:18
  • 1
    This one worked for me. thx – Rodrigo Tavares Nov 5 '19 at 15:14
1

I had tried everthing, and the problem still wouldn't go away until I finally found Mouse suddenly stops working in Ubuntu (running as guest in VirtualBox with Windows host)

ps -ax | grep VBoxClient

resulting e.g. in (among other entries):

1429 ?        Sl      0:00 /usr/bin/VBoxClient --draganddrop

Then kill all processes with

VBoxClient --draganddrop

After killing the processes, my mouse left click worked again. No need to reboot the VM every time!!

| improve this answer | |
  • Saved my day! Did not even have right click. – fiscblog May 12 at 16:55
0

I used htop command and killed (using the opiton 9) one occurrence of compiz. It worked. But is it recommended?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.