0

I use Debian 8 and tonight I tried to switch between the integrated wifi and an wifi usb key using online tutorial. It worked. I did this just to see if wireless connection was better, but it isn't.

Now I would like to switch back to my integrated wifi... I'm using an Acer Aspire 7715. I used "modprobe mt7601Usta" as last command to install/use the wifi usb key, but how can I switch/reinstall (to) my integrated wifi now ? I tried to find the name of my wifi module, using "sudo lshw -C network". I got "AR928X" as wireless product.

  • 1
    Welcome to U&L . The lspci command will give you the required information about the wifi card e,g: lspci -knn | grep Net -A2 . You can edit your question here – GAD3R Dec 27 '17 at 22:33
1

According to the debian wiki the Qualcomm Atheros AR928X Wireless Network Adapter use the ath9k driver. It is included in the linux kernel.

To unload the driver use:

sudo modprobe -rv ath9k

or

sudo rmmod ath9k

To load the driver use:

sudo modprobe -v ath9k

To unload the driver of your USB wifi adapter you can use modprobe -rv mt7601Usta (the best command the -v = verbose) or the rmmod mt7601Usta command.

| improve this answer | |
  • Thank you for your answer. Unfortunately, I got : insmod /lib/modules/3.16.0-4-amd64/kernel/net/wireless/cfg80211.ko modprobe: ERROR: could not insert 'ath9k': Invalid argument after using "sudo modprobe -v ath9k". – Robg Dec 27 '17 at 23:20
  • @Robg Disable the secure boot from your BIOS settings then try sudo modprobe -rv ath9k then sudo modprobe -v ath9k – GAD3R Dec 28 '17 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.