2

I'd like to play Steam Linux games on my laptop. Those games work fine on the Windows partition, but on Debian's one the games run slow. I searched for the reason why they run so slow on Linux, and I found out that my 2nd graphic card wasn't used, so, now I'm trying to activate it. The reason of that post is that I struggle a lot to make it work, here are things I tried:

  • "lspci | grep VGA" tells me that my 2nd card is here:

    00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev Ob)
    
    03:00.0 VGA compatible controller: Advanced Micro Devices, Inc [AMD/ATI] Mars [Radeon HD 8730M]
    
  • "xrandr --listproviders" says the opposite:

    Providers number : 1
    
    Provider 0: id: 0x47 cap: 0xb, Source Output, Sink Offload crtcs, 3 outputs: 5 associated providers: 0 name:Intel
    
  • "glxinfo | grep "OpenGL renderer string"" confirms what xrandr said:

    OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
    
  • BUT "cat /sys/kernel/debug/vgaswitcheroo/switch" says:

    0:IGD:+:Pwr:0000:00:02.0  
    1:DIS: :DynOff:000:03:00.0  
    2:DIS-Audio: :Off:000:03:00.1  
    

Which means that my discrete graphic card is there, but off, but ready to be used. So I tried to activate it using switcheroo:

  • "echo ON > /sys/kernel/debug/vgaswitcheroo/switch"

Nothing happens

  • "echo DIS > /sys/kernel/debug/vgaswitcheroo/switch"

Nothing happens

  • ... Then? "echo DDIS > /sys/kernel/debug/vgaswitcheroo/switch"

Nothing happens

Each time I checked for the switch file, and it's content stayed the same all along, the IGD being powered, and the DIS DynOff, even after reboot. Oh, sometimes eventually switcheroo says: "vga_switcheroo client 0 refused switch" when doing those commands in su mode directly, and I don't really know what that means...

  • Since I had no xorg.conf file, I decided to make one, with the cmd "X -configure" while on recovery mode. Then I moved the file: "cp /root/xorg.conf.new /etc/X11/xorg.conf". But when I reboot with this conf file, my computer gets stuck on the Plymouth boot screen, and the only thing I can access is the tty.

  • Here I tried to backup the /usr/share/X11/xorg.conf.d/ folder and remove it from it's original location, and reboot. Now I don't even get stuck on Plymouth boot screen, after booting I'm redirected on the tty.

At that point, I'm not even sure that the xorg conf is of any use for my original problem, but I see that I also have a problem with it, since freshly generated xorg.conf files makes my computer stuck on splash screen.

  • Results of lsb_release -a :

    LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-

    noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch Distributor ID: Debian Description: Debian GNU/Linux 8.10 (jessie) Release: 8.10 Codename: jessie

  • Results of sudo lshw -C display

    *-display description: VGA compatible controller product: Haswell-ULT Integrated Graphics Controller vendor: Intel Corporation hardware ID: 2 bus information: pci@0000:00:02.0 version: 0b bits: 64 bits clock: 33MHz capabilities: msi pm vga_controller bus_master cap_list rom configuration: driver=i915 latency=0 resources: irq:70 mémoire:d0000000-d03fffff mémoire:c0000000-cfffffff port(s):4000(size=64)

I don't know how to make my AMD graphic card work on that Debian 8 "Jessie" OS, and I probably have a problem with my xorg, so this post is my last hope, pretty much.

UPDATE

Now, after following this post: https://askubuntu.com/questions/648426/discrete-graphics-always-dynoff

I'm stuck on the Plymouth Boot Screen when I boot, and I have this message on both tty1 and Plymout screen (tty7) every 2mn:

INFO: task kworker/u16:0:6 blocked for more than 120 seconds.
Tainted: G C 3.16.0-4-amd64 #1
echo 0 > /proc/sys/kernel/hung_task_timeout_secs disables this message.

Plus, I'm unable to reboot. The /etc/rc.local file edition may seem to be the cause, because when I comment out the line I added, it boots correctly.

On a positive note, my discrete GC is now Pwr in vga_switcheroo. But still not listed in xrandr --listproviders, and I still get the message vga_switcheroo: client 0 refused switch when I try to activate it (echo DIS > /sys/kernel/debug/vgaswitcheroo/switch)

Otherwise, if using radeon rather than fglrx is more complicated, would installing another desktop environment than Gnome like Cinnamon would make my life easier? (Knowing that fglrx is incompatible with Gnome)

UPDATE

I did a bunch of experiments to answer my previous question. I tried to install fglrx-driver and use LightDM (also works with KDM) for display management, and it works. Now, I've tried to use Cinnamon, but it seems that it doesn't support that driver, just like Gnome. So I've installed xfce4 and it seemed to work fine with the driver.

So, now I have KDM for login, and xfce as desktop environment. I open my terminal and type xrandr --listproviders, but still only the Intel device shows up... I created a xorg.conf file using aticonfig --initial, then reboot, and now I have a black screen (black screen for LightDM, tty1 redirection for KDM) meaning that the xorg.conf file generated is not working...

I don't know what to think of it, my xorg configuration might have something to do with it after all!

Reporting another problem: Even though I have managed to make my computer work with a desktop environment along with fglrx, now commands like fglrxinfo, glxinfo & glxgears return the same error:

Xlib: extension "GLX" missing on display ":0.0".

UPDATE

I've asked people on Reddit about my problem, and it seems that my system & graphical stack are too old, so, I'm going to backup my PC and upgrade it from Debian 8 to Debian 9, and hope for the best!

migrated from askubuntu.com Dec 27 '17 at 8:38

This question came from our site for Ubuntu users and developers.

  • I've already tried all switcheroo manipulations (otherwise I wouldn't have made this post). However I didn't mentionned that switcheroo says "client 0 refused switch" when I try to start the discrete GPU – Xobtah Dec 25 '17 at 0:07
  • Please edit the output of lsb_release -a into your post and also sudo lshw -C display as they may useful in pointing you in the right direction. Thank you for helping us help you! – Elder Geek Dec 26 '17 at 13:58
  • Thank you very much for your help! I've made two EDIT sections, the first one is for the commands you asked me, and the second one is a copy of a StackOverflow post I've made that sums up some of the solutions I've tried. Thanks again for your time, this is greatly appreciated! – Xobtah Dec 26 '17 at 19:15
  • Possible duplicate of askubuntu.com/questions/648426/discrete-graphics-always-dynoff – Elder Geek Dec 26 '17 at 21:46
  • Now the GC is indeed OFF but I'm stuck on Plymouth boot screen, Gnome doesn't start – Xobtah Dec 26 '17 at 23:20
0

The solution was finally to install a more recent OS, Debian 9 was enought. Then I installed firmware-amd-graphics from the non-free source, and now it's working: xrandr --listproviders

Providers: number : 2

Provider 0: id: 0x7b cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 5 associated providers: 0 name:modesetting

Provider 1: id: 0x53 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 2 outputs: 2 associated providers: 0 name:OLAND @ pci:0000:03:00.0

Only the names are weird, but once the configuration is done it's not a big deal anymore.

Happy New Year!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.