I start up my computer and get to the rEFInd screen. You should be able to relatively quickly move between the options. In otherwords, if I press the arrow keys to move to another option it should do so almost instantaneously. However it takes like 20 seconds for me to move between the different menu options and select them. Furthermore, if I start Arch it will lag a lot to the point where it is unusable.

I have "worked around" this by starting the computer up and clicking the the restart menu option. Only after doing this will rEFInd and the rest of my computer work normally.

I have seen this question and answer but firstly, I have installed refind through yaourt particularly the package extra/refind-efi 0.11.2-1 so I don't believe I have a ./install.sh --alldrivers. I also do not have a /dev/disk0s1 folder. Finally, although I am using a Mac, I do not have OSX installed, only Arch.

I have ran journalctl --since=today and found some errors:

Dec 22 10:28:05 me kernel: [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x25 (or later)


Dec 22 10:28:05 me kernel: ACPI Error: Needed type [Reference], found [Integer] ffff89506484ca68 (20170728/exresop-103)
Dec 22 10:28:05 me kernel: ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20170728/dswexec-461)
Dec 22 10:28:05 me kernel: ACPI Error: Method parse/execution failed \_PR.CPU0._PDC, AE_AML_OPERAND_TYPE (20170728/pspaarse-550)


Dec 22 10:28:05 me dhcpcd[330]: no valid interfaces found

The rest of the errors seemed to do with GNOME which I don't think should have any relavance to the issue at hand, since although it affects GNOME, it happens before GNOME starts. If something else is needed please let me know I am not sure exactly what to do.


This also seems like a potential candidate:

xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command arch
  • did you try the refind-install script's --alldrivers flag? it probably does the same thing. you could also copy the files manually to the ESP; that package appears to install them to /usr/share/refind. – quixotic Dec 23 '17 at 0:48
  • @quixotic: I tried running that but it says: "The --alldrivers option is meant for creating USB flash drives with (near-) universal boot support. Using it on a hard disk partition runs the risk of creating serious problems, up to and including rendering your computer unbootable. Are you SURE you want to proceed (Y/N)?" I'm not using using USB so I am not sure about doing that. What do you mean by ESP? – Dair Dec 23 '17 at 0:52
  • @quixotic: Running just vanilla refind-install it gives: ESP was found at /boot using vfat Found rEFInd installation in /boot/EFI/refind; upgrading it. – Dair Dec 23 '17 at 0:58
  • ESP is the EFI System Partition; it's the fat32-formatted boot partition on your hard drive where the firmware looks for bootloaders. see man refind-install for a full list of options and their meanings and refer to Rod's site for full refind documentation and EFI basics. – quixotic Dec 23 '17 at 1:01
  • if your research can uncover which drivers are necessary to avoid the problem, just install those. i'm not familiar enough with the mac to tell. i presume the other answers mentioned --alldrivers because they hadn't narrowed it down to a specific set. i cannot say if this is currently advised. – quixotic Dec 23 '17 at 1:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.