0

Suppose I open a text file using Emacs or a picture using Gimp then the Ranger file manager becomes unresponsive till you close this application.

However if I open the same text file say using Gedit or the picture using Eye of Gnome, then the Ranger file manager session is still active and I can use it to move around the folders, browse files and do the usual operations.

Why is this happening?

How to prevent this from happening?

  • you can use strace to have a look at what Ranger is doing. Possibly it's blocked waiting for something. Maybe you can find out what that something is by using strace on the Ranger process. – Tomáš Pospíšek Dec 21 '17 at 19:22
0

Use & which will run the command asynchronously, so ranger will still be usable while you have the application open.

For example, in your rifle.conf use the following line:

mime ^text,  label editor = emacs & -- "$@"

instead of

mime ^text,  label editor = emacs -- "$@"

Similarly suppose you want to open an image with gimp then you can press r in ranger to open a list of available applications. The list might look like:

0 | eog -- "$@"
1 | feh -- "$@"
2 | eom -- "$@"
3 | gimp -- "$@"
:open_with 

Then use 3 & instead of 3 to open the image in gimp while keeping ranger usable.

Sometime ranger may not be configured to recognize the correct application (for example mathematica). You can still choose that application by typing the name of the application at the prompt :open_with. However to keep the ranger still responsive use the flag f as in:

:open_with mathematica f

(the above method to use a flagf is from here)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.