2

I have a fresh install of ubuntu 16.04 on a razer stealth rz09 with nvidia gtx1060 gpu (this gpu being the reason i got the machine). The system freezes often upon login, with both the current and previous kernels. If I use one of the grub options to do a dpkg repair occasionally I am able to boot, and I've managed to do apt-get update and upgrade but still hit the boot hang most of the time. I have a windows partition from which I am writing this but would like to continue with linux since the servers I work off are all linux. This is the second time I've installed linux on this machine, the first time getting stuck after attempting a cuda install - but this time the drivers are all stock! I currently boot with 'secure boot disabled' fwiw. Anyway if someone has some pointers I would appreciate it

  • What is the feedback from the console? – Raman Sailopal Dec 21 '17 at 12:06
  • Some of the answers here may be helpful: askubuntu.com/q/4408/507051 – dessert Dec 21 '17 at 12:17
  • can you provide the contents of /var/log/boot? – vfbsilva Dec 21 '17 at 14:05
  • /var/log/boot.log after a succesful login (no freeze ) pasted here and dmesg output pasted here . This was after a windows boot, which I have heard temporarily allows a subsequent boot into linux. I'll try rebooting now and see if it hangs again. @RamanSailopal I wasnt clear on what kind of feedback you were after – jeremy_rutman Dec 21 '17 at 16:02
  • Press F3 when the system boots, this will switch you from the boot splash screen to the console messages. – Raman Sailopal Dec 21 '17 at 16:10
1

Using 'nomodeset' in grub as described here and then install of driver using standard install worked for me.

0

Well, I had the same problem: My PC was freezing randomly. I tried Ubuntu 16, 17 and 18.04 and everything was the same. I tried several drivers and didn't get a solution. I tried several solutions that I found in the forums and got bad and harmful results.

My solution was: I stopped using the graphical nvidia card, removed it and now I'm using the integrated Intel HD graphics card (Intel® HD Graphics 530 card (Skylake GT2)) and all the problems were solved!

  • see reply above - nomodeset in grub seems to do the trick – jeremy_rutman Mar 26 '18 at 7:09
  • Not for me. My Nvidia graphic Card works fine with Windows, but it doesn work with Ubuntu 17 neither beta 18.04, so the problems are the drivers in Ubuntu. I had removed Nvidia graphic Card and now I using the integrated Intel graphics processor (-Intel® HD Graphics 530 (Skylake GT2) -) and the problem was gone. Well, for me this is the real solution while Ubuntu and partners find the solution of the problem with this graphics card – wmora2 Mar 28 '18 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.