1

We got a few new machines: x3850 x6.

All could pxe boot fine, except one machine, that gives the following kernel panic, looks like an exciting issue:

enter image description here

We cannot even scroll up after the kernel panic occurs, after 30-40 seconds. It hungs so bad, that I cannot even type anything.

Anybody have any clue, what could the problem possibly be? If it is a HW bug, then what to replace? CPUs? Motherboard?

  • the BIOS settings are the exact same vs. working ones
  • the firmware/bios versions are the exact same vs. working ones
  • tried cold boot, the same kernel panic
  • tried to boot with kernel parameters: "acpi=off" - it just did the same kernel panic at ~18 sec, not the usual panic at 30-40 sec.
  • tried: "noapic nomodeset xforcevesa" - panic after 30-40 sec.
  • tried: "acpi=off noapic nomodeset xforcevesa" - panic after 30-40 sec.
  • tried: "isolcpus=0" boot param, same kernel panic, after 30-40 sec.
  • tried to boot a slacko-5.6-PAE.iso - it booted normally! 3.10.5 SMP PAE. But we have to use SLES. The PAE kernel only sees ~65 GByte RAM, if that is a useful info.
  • tried: https://www.memtest86.com/downloads/memtest86-iso.zip to run a simple memtest, but after 59 seconds of run without memory error, the machine freezed. -> UPDATE: The Memtest86+ from: http://www.memtest.org/#downiso doesn't freezes.

Once I seen: "Kernel panic - not syncing: Watchdog detected hard LOCKUP on cpu 18" - there are 4 CPUs in the machine, each has 18 cores, so don't know which one is this..

UPDATE: with the "maxcpus=0" kernel boot parameter, it finally booted, but still investigating, because still said: "A start job is running for Activation of LVM2 logical volumes (Xmin xs / no limit)" - but maybe CPU HW issue?

closed as off-topic by Jeff Schaller, G-Man, Rui F Ribeiro, cas, Archemar Jan 29 '18 at 8:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Rui F Ribeiro, Archemar
If this question can be reworded to fit the rules in the help center, please edit the question.

  • to scroll up try Shift-PageUp. – meuh Dec 20 '17 at 18:32
  • no, it doesn't work, but could record the full terminal with the IMM's recording solution, but nothing interesting there.. – whoonetets Dec 20 '17 at 18:40
  • Is that really a panic? It looks like the machine has continued to run after the stack trace, so it may just be a recoverable error. Does the boot eventually complete or is it hung? – Murray Jensen Dec 21 '17 at 6:57
  • 2
    I think the memtest86 freezing is the nail in the coffin. That tools is basically a minimal OS which rules out this is just the OS. – jdwolf Dec 24 '17 at 6:07
  • Might be a stupid proposition but ... i already had a machine that won't even boot if a strange PS/2 mouse was connected to it. Did you try to boot with other peripherals ? I suggest this as i see some message about your peripherals in the output log you provide us so ... – Carpette Dec 26 '17 at 15:13
0

After an emulex card driver upgrade, it doesn't kernel panic any more.

Version 11.0.270.24 to 11.4.1186.3

Not the answer you're looking for? Browse other questions tagged or ask your own question.