0

We'v got a strange problem. We have multiple bootable Armbian (including 5.25 and 5.30). These are of course not the newest, but we would update them immediately after installation with the usual apt-get upgrade, run from a sudo'd script. This image and this script did not change.

2 weeks ago we last tried this without any problems. Late last week and now we're seeing apt-get upgrade fail on multiple devices, run from multiple base images, all with the same error message:

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable). 

There are existing questions about it, suggesting to manually remove the file (doesn't help us) and to check if there are multiple processes running (no, this is a single script, and it fails in the first apt-get command.)

I suspect the problem is in a repository as that is the only common factor I have been able to identify in all failure cases, and because it's also the only factor that has changed since 2 weeks ago. I just don't understand how that breaks the local /var/lib/dpkg/lock file.

0

Armbian performs an automated update in the background just before the system starts. You only need to wait some minutes to do a manual sudo apt update and sudo apt upgrade. The time the update takes may vary depending your connection, microSD card speeds, ... So check many times till the process is done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.