1

These are things I did Inside [Seat:*] in

/etc/lighdm/lighdm.conf

I changed

greeter-session=lightdm-gtk-greeter
autologin-user=pi
autologin-user-timout=0

and in

/etc/lighdm/lightdm-gtk-greeter

I changed the background to my preferred one by

[greeter]
background=/usr/share/pixmaps/splash.png
user-background=/usr/share/pixmaps/splash.png

I will see the background wallpaper when autologin is not enabled, but I have to log in manually. When auto login enabled I am logged into the black screen with the mouse and no wallpaper.I want the wallpaper to appear in autologin too.I already spend a lot of time on this.I have tried Openbox without lightdm also using feh.But autologin and startx had to be done manually.As I am not well versed with xinit.I am trying to do it for the kiosk to show a wallpaper before loading time taken by chrome to fetch website.

2

If lightdm is configured with autologin-user, it doesn't run any greeter. It immediately opens a session for the given user and hands over to a window manager. Setting your window manager's background should do what you want, e.g. for openbox add something similar to:

xsetbg /usr/share/pixmaps/splash.png &

to your ~/.config/openbox. Note, that openbox must run in session mode, e.g.:

$ cat ~/.xinitrc
/usr/bin/openbox-session

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.