0

I have installed a debian 9 x86 on a VmWare Workstation, and used it few times, then i have been messing with NetBeans and also gnutls library, i was trying to build static one to use in my program, so i removed the one that was in my system. After that, i turned the vm off, and suddenly after ordinary Grub Boot, and some boot logging, only black screen without any cursors or appeared, and it stays forever. So here is some log fist:

screen1

After that:

screen2

And after this, i just got constant black screen

screen3

I have tried to boot in recovery mod and update with apt-get update and apt-get upgrade, but still the same picture. I also tried in the grub menu, i pressed e and entered this (nomodeset):

nomodeset

Then booted with ctrl+x, still the same black screen. Can somepne help, i have a lot of important data, and code project there which i don't want to loose. I haven't changed monitor or videocard. I tried switch on accelerated graphics still doesn't work, basically i didn't touch any vm settings, so i think i messed something inside debian.

2
  • you should crop the fullscreen shots images to the intended content.It will make it way more readable
    – M4rty
    Dec 18, 2017 at 7:44
  • @M4rty sorry, i updated post with more readable images Dec 18, 2017 at 8:03

2 Answers 2

0

I assume you installed your version of the library by deleting the system one? That would explain why apt-get upgrade doesn't do anything. You can reinstall Debian's gnutls via apt-get install --reinstall libgnutls30 in the recovery shell and reboot.

0

The error seems to happen as a GUI session is started.

Try adding this boot option (just like you tried nomodeset):

systemd.unit=multi-user.target

This should bring the system up without starting the GUI components, allowing you to login in text mode. After logging in, go to /var/log/ and check the contents of GUI-related log files, like gdm.log, or Xorg.0.log (if it exists). There might be error messages that describe what is going wrong.

(GDM might be using Wayland instead of Xorg, but I don't know how Wayland does its logging.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .