1

I have brand new laptop with windows 10. Using NVME ssd drive. I am trying to do multiboot using UEFI.

For some reason, grub-mkconfig -o /boot/grub/grub.cfg is not finding my windows partition. I have my UEFI partition mounted to /boot.

I have installed grub with grub-install --target=x86_64-efi --efi-directory=/boot. I can see /boot/EFI/gentoo along with the windows directory.

Any ideas how to make grub-mkconfig see my windows 10 partition?

0

You need sys-boot/os-prober to detect windows. From the Grub2 Gentoo wiki page:

Additional software

Optionally, install the os-prober utility (provided through the sys-boot/os-prober package) to have GRUB2 probe for other operating systems when running the grub-mkconfig command. In most instances, this will enable GRUB2 to automatically detect other operating systems including Windows 7, 8.1, 10, other distributions of Linux, etc. root

emerge --ask --newuse sys-boot/os-prober

The GRUB2 (and optionally sys-boot/os-prober) installations do not automatically enable the boot loader. These only install the software on the operating system, but to install the boot loader to the system itself (so that it is used when booting the system), additional steps need to be taken, which are covered in the Configuration section.

And:

os-prober and UEFI in chroot

The sys-boot/os-prober utility is used to discover alternate installs, such as Microsoft Windows. To function properly, it needs to have access to information from the live environment's udev to test for the EFI System Partition.

Run these commands in the host environment to provide the required files (example shows Gentoo mounted on /mnt/gentoo like in the Handbook):

root #mkdir -p /mnt/gentoo/run/udev 
root #mount -o bind /run/udev /mnt/gentoo/run/udev 
root #mount --make-rslave /mnt/gentoo/run/udev`

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.