I have recently installed Debian 9, and I have been facing many problems since then.

The hard drive was previously used for a Windows install, and is not completely formatted, so it contains two ntfs partitions and they are giving me a lot of problems recently. If I log-off from a user account and log-on into another one, those partitions are still mounted to the previous user (/media/PREVIOUS_USER/) and I could not access them. I had to reboot the system to correct it. I solved it by editing the fstab file, the contents of fstab are:

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
 # / was on /dev/sda6 during installation  
UUID=c714d29d-2838-4a9c-8ce5-e069a002409e /               ext4    errors=remount-ro 0       1  
 # /boot was on /dev/sda1 during installation
UUID=351792be-2150-43b8-8319-27f2a96b1d26 /boot           ext4    defaults        0       2  
 # swap was on /dev/sda5 during installation   
UUID=4817f1b5-4c86-4f33-8122-850295d1fcb1 none            swap    sw              0       0  
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0  
/dev/sr1        /media/cdrom1   udf,iso9660 user,noauto     0       0  
UUID=3E4ACD924ACD46FD   /media/hddmount1/   ntfs-3g     noauto,user,rw  0   0  
UUID=C84EBF694EBF4EC6   /media/hddmount2/   ntfs-3g     noauto,user,rw  0   0 

So far it works correctly. Now I want to change the permissions of certain folders and when I use chmod, it simply does not work and no error message is shown. The permissions were 0777 before using chmod and are still is 0777. Thunar(default file manager in Debian) cannot edit the permissions through the Folder/file properties dialogue box. I want these partitions to be accessible for every user in my Debian installation(I have no Windows installations as of now) but restrict access to certain folders in these partitions.
What is to be done? Or is it possible?

  • 3
  • @Jesse_b Thanks for the edit. I tried, but I couldn't. – RogUE Dec 17 '17 at 15:12
  • 1
    @jasonwryan is the answer there still relevant? I haven't done this in years, but I don't have a ntfs-3g.usermap command on my arch. Has this changed since ntfs-3g has been integrated into the kernel? – terdon Dec 17 '17 at 15:28
  • @terdon No idea, I haven't used Windows in a very long time. – jasonwryan Dec 17 '17 at 17:15
  • Yeah, me neither, so maybe we shouldn't dupe it if we're not sure. – terdon Dec 17 '17 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.