3

Few days after installed OpenBSD, I got the following error:

$ libreoffice                                                                  
/usr/local/lib/libreoffice/program/soffice[171]: /usr/local/lib/libreoffice/program/oosplash: Permission denied
$ 

Same even with root. oosplash has execute permissions:

$ ls -lah /usr/local/lib/libreoffice/program/oosplash
-rwxr-xr-x  1 root  bin  46.2K Oct  2 22:52 /usr/local/lib/libreoffice/program/oosplash
$ 
$ cat -n /usr/local/lib/libreoffice/program/soffice | tail -1
   171  exec $RRCHECK $VALGRINDCHECK $STRACECHECK "$sd_prog/oosplash" "$@"
$ 

I am using the following versions:

$ pkg_info | grep libreoffice
libreoffice-5.2.7.2p6v0 multi-platform productivity suite
$ 
$ uname -mrs
OpenBSD 6.2 amd64
$ 

The Q: how can I debug the problem with LibreOffice?

1

1 Answer 1

0

The binaries of LibreOffice are installed in /usr/local. You need to add wxallowed (as mount option) in /etc/fstab to the partition which contains the directory /usr/local.

3
  • yes :) this was the problem, I forgot that for hardening reasons, I removed the wxallowed, but didn't it worked before without it?
    – Hessnov
    Dec 18, 2017 at 7:11
  • I don't remember when the wxallowed option was enforced but there was a release which only showed a warning in the dmesg. Dec 18, 2017 at 21:43
  • it was enforced from 6.0: openbsd.org/faq/upgrade60.html - things are getting better :) only some ports, ex.: LibreOffice, Google Chrome has security problems regarding W^X..
    – Hessnov
    Feb 5, 2018 at 21:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .