3

So I am using Arc as my GTK theme, and applied it like this

[Settings]
gtk-icon-theme-main=Arc
gtk-theme-name=Arc
gtk-application-prefer-dark-theme=true

in ~/.config/gtk-3.0/settings.ini

To enable it for GTK2, I did this:

gtk-theme-name="Arc"
gtk-icon-theme-name="Arc"
gtk-application-prefer-dark-theme="true"

in ~/.gtkrc-2.0. However, gimp and some other applications (I assume they are GTK2) are light.. Others have correctly been given the Arc Dark theme and the icon-theme as well..

How do I enable the dark-mode for GTK2?

  • Solved it by adding Arc-Dark and "Arc-Dark" on gtk-theme-name for both Gtk2 and Gtk3.. – vegarab Dec 16 '17 at 16:50
  • Consider to expand the comment into a proper answer. Yes, you can answer your own question. – clearkimura Dec 16 '17 at 18:33
2

Using the name Arc-Dark for both GTK2 and GTK3 solves the issue.

GTK3:

[Settings]
gtk-icon-theme-main=Arc-Dark
gtk-theme-name=Arc-Dark

GTK2:

gtk-theme-name="Arc-Dark"
gtk-icon-theme-name="Arc-Dark"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.