1

Here is my problem and what I tried:

**jan@debian:~$ sudo apt-get remove openoffice**
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libreoffice-core : Depends: libreoffice-common (> 1:4.3.3) but it is not going to be installed
 libreoffice-java-common : Depends: libreoffice-common but it is not going to be installed
 openoffice-brand-base : Depends: openoffice but it is not going to be installed
 openoffice-brand-calc : Depends: openoffice but it is not going to be installed
 openoffice-brand-de : Depends: openoffice but it is not going to be installed
 openoffice-brand-draw : Depends: openoffice but it is not going to be installed
 openoffice-brand-impress : Depends: openoffice but it is not going to be installed
 openoffice-brand-math : Depends: openoffice but it is not going to be installed
 openoffice-brand-writer : Depends: openoffice but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
**jan@debian:~$ sudo apt-get remove libreoffice**
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'libreoffice' is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libreoffice-core : Depends: libreoffice-common (> 1:4.3.3) but it is not going to be installed
 libreoffice-java-common : Depends: libreoffice-common but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
**jan@debian:~$ sudo apt-get -f install**
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  alien debugedit librpmbuild3 librpmsign1 lsb-core lsb-security pax rpm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libreoffice-common
Suggested packages:
  libreoffice-style-crystal libreoffice-style-hicontrast libreoffice-style-oxygen libreoffice-style-sifr libreoffice-style-tango
Recommended packages:
  xfonts-mathml
The following NEW packages will be installed:
  libreoffice-common
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
15 not fully installed or removed.
Need to get 0 B/22,3 MB of archives.
After this operation, 81,2 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 209711 files and directories currently installed.)
Preparing to unpack .../libreoffice-common_1%3a4.3.3-2+deb8u9_all.deb ...
Unpacking libreoffice-common (1:4.3.3-2+deb8u9) ...
dpkg: error processing archive /var/cache/apt/archives/libreoffice-common_1%3a4.3.3-2+deb8u9_all.deb (--unpack):
 trying to overwrite '/usr/bin/soffice', which is also in package openoffice-debian-menus 4.1.3-9783
rmdir: failed to remove ‘/var/lib/libreoffice/share/prereg/’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice/share/’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice/program/’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice’: No such file or directory
Processing triggers for shared-mime-info (1.3-1) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-icon-theme (3.12.0-1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-common_1%3a4.3.3-2+deb8u9_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
**jan@debian:~$ sudo apt-get clean**
**jan@debian:~$ sudo apt-get autoclean**
Reading package lists... Done
Building dependency tree       
Reading state information... Done
**jan@debian:~$ sudo dpkg --configure -a**
dpkg: dependency problems prevent configuration of libreoffice-java-common:
 libreoffice-java-common depends on libreoffice-common; however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-java-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-sdbc-hsqldb:
 libreoffice-sdbc-hsqldb depends on libreoffice-java-common (>= 1:4.3.3~); however:
  Package libreoffice-java-common is not configured yet.

dpkg: error processing package libreoffice-sdbc-hsqldb (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-core:
 libreoffice-core depends on libreoffice-common (>> 1:4.3.3); however:
  Package libreoffice-common is not installed.

dpkg: error processing package libreoffice-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-calc:
 libreoffice-calc depends on libreoffice-core (= 1:4.3.3-2+deb8u9); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-calc (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-uno:
 python3-uno depends on libreoffice-core (= 1:4.3.3-2+deb8u9); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package python3-uno (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-base-drivers:
 libreoffice-base-drivers depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-base-drivers (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-draw:
 libreoffice-draw depends on libreoffice-core (= 1:4.3.3-2+deb8u9); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-draw (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-avmedia-backend-gstreamer:
 libreoffice-avmedia-backend-gstreamer depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-avmedia-backend-gstreamer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-writer:
 libreoffice-writer depends on libreoffice-core (= 1:4.3.3-2+deb8u9); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-writer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-impress:
 libreoffice-impress depends on libreoffice-core (= 1:4.3.3-2+deb8u9); however:
  Package libreoffice-core is not configured yet.
 libreoffice-impress depends on libreoffice-draw (= 1:4.3.3-2+deb8u9); however:
  Package libreoffice-draw is not configured yet.

dpkg: error processing package libreoffice-impress (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-sdbc-firebird:
 libreoffice-sdbc-firebird depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-sdbc-firebird (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-base:
 libreoffice-base depends on libreoffice-base-drivers (= 1:4.3.3-2+deb8u9); however:
  Package libreoffice-base-drivers is not configured yet.
 libreoffice-base depends on libreoffice-core (= 1:4.3.3-2+deb8u9); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-math:
 libreoffice-math depends on libreoffice-core (= 1:4.3.3-2+deb8u9); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-math (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-report-builder-bin:
 libreoffice-report-builder-bin depends on libreoffice-base; however:
  Package libreoffice-base is not configured yet.
 libreoffice-report-builder-bin depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-report-builder-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-base-core:
 libreoffice-base-core depends on libreoffice-core (= 1:4.3.3-2+deb8u9); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-base-core (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libreoffice-java-common
 libreoffice-sdbc-hsqldb
 libreoffice-core
 libreoffice-calc
 python3-uno
 libreoffice-base-drivers
 libreoffice-draw
 libreoffice-avmedia-backend-gstreamer
 libreoffice-writer
 libreoffice-impress
 libreoffice-sdbc-firebird
 libreoffice-base
 libreoffice-math
 libreoffice-report-builder-bin
 libreoffice-base-core
**jan@debian:~$ sudo apt-get -u dist-upgrade**
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libreoffice-core : Depends: libreoffice-common (> 1:4.3.3) but it is not installed
 libreoffice-java-common : Depends: libreoffice-common but it is not installed
E: Unmet dependencies. Try using -f.
**jan@debian:~$ sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade**
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libreoffice-core : Depends: libreoffice-common (> 1:4.3.3) but it is not installed
 libreoffice-java-common : Depends: libreoffice-common but it is not installed
E: Unmet dependencies. Try using -f.
**jan@debian:~$ sudo apt-get remove --dry-run libreoffice-java-common**
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libreoffice-core : Depends: libreoffice-common (> 1:4.3.3) but it is not going to be installed
 libreoffice-sdbc-hsqldb : Depends: libreoffice-java-common (>= 1:4.3.3~) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
**jan@debian:~$ sudo apt-get -u dist-upgrade**
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libreoffice-core : Depends: libreoffice-common (> 1:4.3.3) but it is not installed
 libreoffice-java-common : Depends: libreoffice-common but it is not installed
E: Unmet dependencies. Try using -f.
**jan@debian:~$ sudo apt-get -f install**
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  alien debugedit librpmbuild3 librpmsign1 lsb-core lsb-security pax rpm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libreoffice-common
Suggested packages:
  libreoffice-style-crystal libreoffice-style-hicontrast libreoffice-style-oxygen libreoffice-style-sifr libreoffice-style-tango
Recommended packages:
  xfonts-mathml
The following NEW packages will be installed:
  libreoffice-common
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
15 not fully installed or removed.
Need to get 22,3 MB of archives.
After this operation, 81,2 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://ftp.de.debian.org/debian/ jessie/main libreoffice-common all 1:4.3.3-2+deb8u9 [22,3 MB]
Fetched 22,3 MB in 4s (4.577 kB/s)             
(Reading database ... 209711 files and directories currently installed.)
Preparing to unpack .../libreoffice-common_1%3a4.3.3-2+deb8u9_all.deb ...
Unpacking libreoffice-common (1:4.3.3-2+deb8u9) ...
dpkg: error processing archive /var/cache/apt/archives/libreoffice-common_1%3a4.3.3-2+deb8u9_all.deb (--unpack):
 trying to overwrite '/usr/bin/soffice', which is also in package openoffice-debian-menus 4.1.3-9783
rmdir: failed to remove ‘/var/lib/libreoffice/share/prereg/’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice/share/’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice/program/’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice’: No such file or directory
Processing triggers for shared-mime-info (1.3-1) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-icon-theme (3.12.0-1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-common_1%3a4.3.3-2+deb8u9_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

here is my sources.list:

**$ cat /etc/apt/sources.list**

deb http://ftp.de.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.de.debian.org/debian/ jessie main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free
deb http://ftp.de.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.de.debian.org/debian/ jessie-updates main contrib non-free

deb http://download.virtualbox.org/virtualbox/debian jessie contrib
deb https://dl.winehq.org/wine-builds/debian/ jessie main

And this is my Linux version:

**jan@debian:~$ lsb_release -a**
LSB Version:    core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch
Distributor ID: Debian
Description:    Debian GNU/Linux 8.10 (jessie)
Release:    8.10
Codename:   jessie
jan@debian:~$ uname -a
Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.51-2 (2017-12-03)
x86_64 GNU/Linux
1
  • 1
    Remove openoffice-debian-menus first. Dec 14, 2017 at 12:32

1 Answer 1

0

Looks to me like you're trying to remove openoffice (wow, I sound like Clippy). Try removing all the packages in one go:

apt-get remove libreoffice* openoffice*

As an alternative, you can run dpkg -l | grep office and run apt-get remove followed by the list of individual packages you want removed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .