186

I am using Ubuntu 16.04 LTS . I have python3 installed. There are two versions installed, python 3.4.3 and python 3.6 . Whenever I use python3 command, it takes python 3.4.3 by default. I want to use python 3.6 with python3.

python3 --version shows version 3.4.3

I am installing ansible which supports version > 3.5 . So, whenever, I type ansible in the terminal, it throws error because of python 3.4

  • What is the command used to execute python 3.6 ? – user264413 Dec 13 '17 at 9:22
  • command is :- python3.6 – codeclue Dec 13 '17 at 9:23
  • 4
    What does your sudo update-alternatives --config python3 say? – Mikael Kjær Dec 13 '17 at 9:35
  • 1
    update-alternatives: error: no alternatives for python3 – codeclue Dec 13 '17 at 9:38
  • 1
    @Mikael Different Python versions are not alternatives on Ubuntu. The OS relies on a specific version (or versions) being installed. – wjandrea Jan 1 at 19:22
240

From the comment:

sudo update-alternatives --config python

Will show you an error:

update-alternatives: error: no alternatives for python3 

You need to update your update-alternatives , then you will be able to set your default python version.

sudo update-alternatives --install /usr/bin/python python /usr/bin/python3.4 1
sudo update-alternatives --install /usr/bin/python python /usr/bin/python3.6 2

Then run :

sudo update-alternatives --config python

Set python3.6 as default.

Or use the following command to set python3.6 as default:

sudo update-alternatives  --set python /usr/bin/python3.6
| improve this answer | |
  • 7
    This answer will probably break apt. After selecting a different version of python try to run sudo apt update. If it gives you an error like ModuleNotFoundError: No module named 'apt_pkg' you want to go to /usr/lib/python3/dist-packages and create the symlink: ln -s apt_pkg.cpython-{34m,36m}-x86_64-linux-gnu.so. – Giacomo Alzetta May 30 '19 at 8:22
  • 1
    @GAD3R Thanks. I've managed to create a symlink manually to point to the Python 3.6. Also, I don't have 3.7 installed. – Slava Fomin II Sep 11 '19 at 8:58
  • 1
    Making python3 point to python3.8 with this method broke gnome-terminal for me. – Boris Oct 17 '19 at 23:49
  • 8
    @Johny I just added alias python="python3.8" to ~/.bash_profile – Boris Nov 25 '19 at 21:02
  • 2
    Works fine in Ubuntu 18.04 LTS without breaking APT. Note to those confused: if you are getting the error: no alternatives for python message, then you need to run the --install commands following first (replacing the python versions you want to use as appropriate, and the numbers at the end are just for order) then you run the --config command again and you will be asked which version you want to use by default. – tpartee Feb 25 at 6:50
37

You can achieve this by applying below simple steps -

  1. Check python version on terminal - python --version
  2. Get root user privileges. On terminal type - sudo su
  3. Write down the root user password
  4. Execute this command to switch to python 3.6 -
    update-alternatives --install /usr/bin/python python /usr/bin/python3 1
  5. Check python version - python --version
  6. Done.
| improve this answer | |
  • Works fine on Ubuntu 18.04. so simple than other solutions. thanks a lot – Mohammad Heydari Aug 13 '19 at 23:29
  • 1
    This worked: sudo update-alternatives --set python /usr/bin/python3.7 python --version – Sam-T Dec 23 '19 at 0:28
  • Also works on Pop! OS – Francis Jan 18 at 3:27
  • 2
    What is the point of step 3? – goonerify Feb 1 at 18:17
  • @goonerify it's the second half of step 2 – Cameron Tacklind Mar 30 at 11:16
14

Using these commands can help you:

  1. check the version of python: ls /usr/bin/python*
  2. alias: alias python='/usr/bin/pythonxx' (add this to . ~/.bashrc)
  3. re-login or source . ~/.bashrc
  4. check the python version again: python --version
| improve this answer | |
  • thanks but after restarting the computer the main python would be still the ex python 2.7 – Mohammad Heydari Aug 13 '19 at 23:25
  • 2
    You should add the script to modify the default in ~/.bashrc. Then you will make it work forever. – Newt Nov 4 '19 at 13:32
  • like this: export python=/home/xxx (your py3 directory) – Newt Nov 4 '19 at 13:40
6

Create symlink for /usr/bin/python3. In my LinuxMint:

# ls -lh /usr/bin/python3 /usr/bin/python
lrwxrwxrwx 1 root root 9 ноя 24  2017 /usr/bin/python -> python2.7
lrwxrwxrwx 1 root root 9 сен  6  2017 /usr/bin/python3 -> python3.5

# mv /usr/bin/python /usr/bin/python.bak
# cp /usr/bin/python3 /usr/bin/python
# python --version
Python 3.5.2
| improve this answer | |
  • This broke apt installer. – jws May 5 at 21:30
6

First check that you have a python3.6 folder?

ls /usr/bin/python3.6

If you have "python3.6" folder, you are good to go. Now update-alternatives

sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.6 1

then update new config for python3

sudo update-alternatives --config python3

Finally, check default python3 version:

python3 --version
| improve this answer | |
5

An easy answer would be to add an alias for python3.6.

Just add this line in the file ~/.bashrc : alias python3="python3.6", then close your terminal and open a new one. Now when you type python3 xxx it gets translated to python3.6 xxx.

This solution fixes your problem without needing to tweak your system too heavily.

EDIT :

As Mikael Kjær pointed out, this is a misconfiguration of ansible with your system.

As seen here :

Set the ansible_python_interpreter configuration option to /usr/bin/python3. The ansible_python_interpreter configuration option is usually set per-host as an inventory variable associated with a host or group of hosts:

  # Example inventory that makes an alias for localhost that uses python3
  [py3-hosts]
  localhost-py3 ansible_host=localhost ansible_connection=local

  [py3-hosts:vars]
  ansible_python_interpreter=/usr/bin/python3

As seen here about the config file :

Changes can be made and used in a configuration file which will be processed in the following order:

* ANSIBLE_CONFIG (an environment variable)
* ansible.cfg (in the current directory)
* .ansible.cfg (in the home directory)
* /etc/ansible/ansible.cfg
| improve this answer | |
5

if you have multiple version of python in your system. You just need to update the symbolic link of python inside /usr/bin/

root@irshad:/usr/bin# ls -lrth python*
lrwxrwxrwx 1 root root    9 Apr 16  2018 python -> python2.7
-rwxr-xr-x 1 root root 3.6M Nov 12  2018 python2.7
-rwxr-xr-x 2 root root 4.4M May  7 14:58 python3.6

In above example if you see the output of python --version you will get python2.7

Now update the python symlink using below command-

root@irshad:/usr/bin# unlink python
root@irshad:/usr/bin# ln -s /usr/bin/python3.6 python
root@irshad:/usr/bin# python --version
Python 3.6.8
| improve this answer | |
1

You can change the simbolic link by ln -sf python3.6 python3 inside /usr/bin. With this when you call python3 it will execute python3.6

| improve this answer | |
0

update-alternatives is to change system symlinks to user-defined/admin-defined symlinks. If you have multiple versions of python3 installed in your system and want to control which python3 version to invoke when python3 is called. Do the following

sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.4 1
sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.5 2

Run below command if you want to change priority in the future.

update-alternatives --config python3

Explanation:-

sudo update-alternatives --install <symlink_origin> <name_of_config> <symlink_destination> <priority>

You can go on change name_of_config to python4, but then you have to invoke update-alternatives --config with python4 to reconfigure.

Using this approach you are able to control system python version and python3 version separately.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.