2

I am trying to install a Ralink wifi adapter in Armbian. I have look this here but it did not

lsusb
Bus 004 Device 003: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter

OS Version:

Armbian 5.35 Bananapi

Ubuntu xenial default 3.4.113

lsmod
Module                  Size  Used by
bnep                   14360  2
disp_ump                 850  0
mali_drm                2611  1
drm                   214553  2 mali_drm
cpufreq_userspace       3540  0
mt7601Usta            806104  0
spidev                  6339  0
mali                  112222  0
ump                    61778  4 mali,disp_ump
a20_tp                  3294  0
8021q                  18659  0
garp                    6084  1 8021q
stp                     2028  1 garp
llc                     5421  2 stp,garp
sunxi_ir                4044  0
hidp                   17740  0
rfcomm                 58820  0
hci_uart               25074  0
bluetooth             265449  10 bnep,hidp,hci_uart,rfcomm

ifconfig
eth0      Link encap:Ethernet  HWaddr 02:d5:03:c2:82:df
          inet addr:192.168.1.31  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::d5:3ff:fec2:82df/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1696 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1358 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1542624 (1.5 MB)  TX bytes:244546 (244.5 KB)
          Interrupt:117 Base address:0x8000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:112 errors:0 dropped:0 overruns:0 frame:0
          TX packets:112 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8956 (8.9 KB)  TX bytes:8956 (8.9 KB)

iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

bond0     no wireless extensions.

dmesg output here

  • 1
    It "did not" what? Not work? What happened after you modprobed mt7601Usta? dmesg output? Any errors? – dirkt Dec 12 '17 at 11:11
  • I updated the question. I added lsmod, dmesg, ifconfig, iwconfig output.Clearly I am beginner. I do not know how to make WiFi choice. I can not see ra0 after iwconfig. – Alparslan Bagriyanik Dec 12 '17 at 13:17
  • Which solution did you try to do from there? The first one having the highest votes (I mean getting the source for the drivers and compiling them)? – Dmitry Dec 14 '17 at 12:05
  • Only the 1st answer there has any potential working in your case. Did you try it? What errors did it give you? – Dmitry Dec 14 '17 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.