2

So, due to what I assume to be a loose ATX connector my system powered down unexpectedly. Which is bad. When I run btrfs check I find a mile long list of extent holes. Fortunately they are limited to the volume specificly meant to handle data that changes a lot (logs and cache), and the data I actually care about seems okay.

I ran a scrub and the effected volume seems to be okay, but I still have these holes. I don't really want to use btrfs check to fix them until I know for sure if that is wise.

So...what do I do and what can I expect? I'm pretty sure repairing is the way to go, but anytime data is involved I always like to be sure.

edit: One thing I should mention is that volume is functional as is. It has my OS on it as well as /boot.

edit2: Also, for what it's worth, I'm running kernel version 4.14.4-1-ARCH with btrfs-progs version 4.14-1.

  • You seems to already know the answer....multiple inconsistencies expected in non-important files. – Rui F Ribeiro Dec 11 '17 at 20:29
  • 1
    No, I don't know, I suspect. I'm not system administrator. I have above average knowledge of stuff, and my Goggle-fu is pretty decent, but when Google can't help me I have to ask for help. When it comes to data, even data that isn't especially valuable, I don't take chances. That volume also has my OS on it. I could rsync my back up to a new volume, but I'd rather not. – Nero gris Dec 11 '17 at 20:42
0

This isn't much of an answer, but for those of you who might come accross this question because you yourself have a similar issue I figure I should mention the result.

It was impractical to leave things be, so I went ahead an fixed the problem with btrfs check --repair from my fall back installation of Arch. On subsequent checks, no errors were found, nor when I followed up with a scrub were there any errors. I then went ahead a compared the volume against backups, but there was so much to go through I can't decide if there is anything to worry about. I got through about 25% of it and didn't find anything that concerned me, and my system is working fine. Consider it has the OS, cache/config, and other such things that make the system run properly, everything is most likely okay.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.