1

I'm running Zorin OS 12.2 (downloaded and installed in September 27th this year) on a Dell XPS 13. I installed Zorin instead of the pre-installed Windows 10 (I'm aware that Dell XPS ships with Ubuntu pre-installed, but the one I have was ordered bulk via my workplace).

For the past six days the system has been unable to boot. I end up in BusyBox (v1.22.1 (Ubuntu 1:1.22.0-15ubuntu1)) with an initramfs prompt. In the BIOS it lists Windows Boot Manager (twice). I wonder if I did something wrong when I installed Zorin, as I thought I got completely rid of Windows.

I suspect that the error (that causes me to end up in BusyBox) stems from me sometimes had to force-shut down my laptop because the screen would not turn on after the laptop had been folded together, or after I had accidentally pushed the power button (which just turns on the screen on my other laptop if it's been idle for a while and has turned off the screen). At least it appears that Zorin can't handle my laptop being treated like the hybrid PC it was built to be. This could have nothing to do with the problem, but the problem arose when I turned the computer on after (yet again) having had to force-shut down becuase I pressed the power button to turn the screen back on.

I tried booting into Zorin with Linux 4.10.0-38 (and 37 and 33) via "Advanced options for Zorin GNU/Linux", instead of 4.10.0-40 which is listed first, but the same thing happens. I also tried booting 4.10.0-40 in recovery mode, but that doesn't make a difference either.

I've tried running Boot Repair (https://help.ubuntu.com/community/Boot-Repair) from the live USB. The output is located here: http://pastebin.ubuntu.com/26155667/.

I tried following a bunch of suggestions from askubuntu and ubuntuforums:

  1. https://ubuntuforums.org/showthread.php?t=1561735
  2. https://askubuntu.com/questions/516217/alert-dev-disk-by-uuid-xxxxxxxxx-does-not-exist-dropping-to-a-shell - was unable to do this. See Screenshot.
  3. https://askubuntu.com/questions/137655/boot-drops-to-a-initramfs-prompts-busybox
  4. https://ubuntuforums.org/showthread.php?t=1018403
  5. https://ubuntuforums.org/showthread.php?t=2112153 (Couldn't try out the suggestions from ahallubuntu since I can only see the live USB and not the laptop's drive when accessing via the live USB. Didn't try the other solutions as they all specifically talked about encrypted drives and I didn't encrypt my drive.)
  6. https://ubuntuforums.org/showthread.php?t=765195&page=33&p=6581939#post6581939 (via link from source 4)

Writing "exit" as suggested in source 3, I get:

Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
   - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules: is /dev)
ALERT! UUID=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX does not exist. Dropping to a shell!

When trying fsck /dev/sda1 (cf. source 3), I get the message:

fsck from util-linux 2.27.1
fsck: error 2 (No such file or directory) while executing fsck.ext2 for dev/sda1

I also tried with sda2 which gave the same result.

When trying Amith KK's suggestion in source 3, I get nothing with the first line:

zorin@zoring:~$ sudo fdisk -l|grep Linux|grep -Ev 'swap'
zorin@zoring:~$ 

uname -a (cf. source 4) gives me:

Linux (none) 4.10.0-40-generic #44~16.04.1-Ubuntu SMP Thu Nov 9 15:37:44 UTC 2017 x86_64 GNU/Linux

I tried the solution suggested by quixote in source 1, but it doesn't show me any files like he suggests it would:

grub> ls
(hd0) (hd0,gpt3)  (hd0,gpt2)  (hd0,gpt1)
grub> ls (hd0,3)
    Partition hd0,3: Filesystem type ext* - Last modification time 2017-12-04 Monday, UUID XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX - Partition start at 8705024KiB - Total size 419690496KiB
grub> ls (hd0,2)
    Partition hd0,2: No known filesystem detected - Partition start at 513024KiB - Total size 8192000KiB
grub> ls (hd0,1)
    Partition hd0,1: Filesystem type fat, UUID YYYY-YYYY - Partition start at 1024KiB - Total size 512000KiB
grub> ls (hd0)
    Device hd0: No known filesystem detected - Sector size 512B - Total size 500107608KiB

I also tried using blkid as hhoyt suggests in source 1, but like with source 5 it doesn't look like it shows anything other than the live USB. I get:

root@zorin:~# blkid
/dev/loop0: TYPE="squashfs"
/dev/sda1: UUID="ZZZZ-ZZ-ZZ-ZZ-ZZ-ZZ-ZZ" LABEL="Zorin OS 12.2 Core" TYPE="iso9660" PTUUID="239ad0b8" PTTYPE="dos" PARTUUID="239ad0b8-01"
/dev/sda2: SEC_TYPE="msdos" UUID="398E-230F" TYPE="vfat" PARTUUID="239ad0b8-02"

... which looks very similar to the output I get from trying the solution in source 2. If I try sudo mount /dev/sda1 /mnt I get /dev/sda1 is already mounted or /mnt busy.

Adding all_generic_ide to the kernel boot parameter, as suggested in source 6 (I didn't have a line starting with kernel but instead had a very similar one starting with Linux and tried that one), didn't help .

Does anyone have an idea what could be wrong and how/if I could fix it? (e.g. from looking at the Boot Repair output at http://pastebin.ubuntu.com/26155667/)?

0

blkid is only seeing the USB drive at /dev/sda.

Your laptop's HDD/SSD is not working. It is likely dead to hardware failure. You will most likely need to replace it.

I hope your backups are recent and working.

  • Thanks for your answer. Fortunately I use cloud storage for pretty much everything. It's just very bothersome to have to set up the entire system again. This might sound stupid, but is there any way to make sure that it's the SSD that's dead and not some other issue that's causing this? – Idall Dec 12 '17 at 19:39
  • @Idall You can try removing the drive and connecting it to another computer to see if it still works. – Mioriin Dec 14 '17 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.