1

Problem: Addons open a window, but the title bar says at the very beginning "moz-extension://....", there is no title preface. More importantly the window is completely blank; if I right click (but not left click) inside the window, or resize the window, then the content paints.

Here is the bug report:

1402110 - chrome.windows.create() ignores titlePrefix and fails to paint content

Mozilla has it marked as "won't fix".

The problem for me is that users don't know they can resize the window or otherwise force it to redraw the contents, so it creates a lot of support problems. I cannot change Firefox code or any addon code.

However, maybe KDE or Xorg or Linux can provide me with a temporary workaround? Does anyone have any suggestions?

I thought I could use a KDE Window Rule (System Settings > Window Management > Window Rules), but I don't have experience using them and I have not been able to come up with the correct rule so far.

I tried matching Window title substring on "moz-extension://" and specifying a size to apply initially. I also tried KDE's "Detect Window Properties" and matched on those provided. Either way, it is not matching the window because there is no effect in changing the window size.

1

I did get this to work:

Have an affected Firefox Addon window open.

Open KDE System Settings. Click Window Management. Then click Window Rules. Click "New..." to add a new rule.

Click "Detect Window Properties". The mouse cursor will change. Now click on the Firefox Addon window previously opened.

As a result of that click, a new dialog window will pop up showing the window properties for the Firefox Addon window. Check the boxes for Window Role, Window Type and Window Title. Click OK and those rules are applied to the "Window Matching" tab of the new Window Rule. I suggest loosening the matches a bit. For example, I edited the window title and used a substring match instead of an exact match.

Now switch to the Size & Position Tab of the new Window Rule. I used "Maximized Verticallly" and Force and "Yes".

Click "OK" to save. Then click "Apply". Then exit System Settings. The issue should be resolved now.

1

There is an even better fix. It comes from here: https://bugzilla.mozilla.org/show_bug.cgi?id=1402110#c11

Steps:

  1. Load about:config?filter=extensions.webextensions.remote in the Firefox address bar. This should display the extensions.webextensions.remote on about:config directly.
  2. Double-click on the preference to set it to true.
  3. Restart the web browser.

Comment # 11 on Bug 1402110 from jingyu9575 at 2017-12-10 17:48:40 PST

One of my extension is also affected. When testing I find that it is more related to disabling the feature "out of process extensions" (enabled by default in Windows, disabled by default in Linux). The bug is seen when the feature is disabled in Windows, and not seen when it is enabled in Linux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.