0

I was installing Kali Linux 2016.2 64-bit on my laptop. In my laptop, hard disk is always denoted by sda while flash drives by sdb or sdc.

But during the installation, while selecting partition on which the system was to be installed, I noticed that the flash drive was shown as sda while hard disk by sdb, I installed Kali Linux on /dev/sdb2 (the second partition of hard drive, which is normally denoted as /dev/sda2).

On booting the system after the install, grub menu showed up normally but Kali did not boot normally, it showed me error message: something like,

/dev/sdb2 cannot be found

and showed an (initramfs) console.

I found that my computer switches the name of hard disk from sda to sdb in the presence of a flash drive (which becomes sda, while successive flash drives shows up as sdc, etc). So In the absence of flash drive, the system does not boot and shows error and initramfs console.

How to fix labelling of drives?

Please help.

0

You will probably need to manually mount your root filesystem to /mnt or similar, make sure that /dev, /proc and /sys are available within it (by mount --bind commands, perhaps?), then chroot to your root filesystem, fix your /etc/fstab and regenerate your initramfs file so that it will contain the fixed /etc/fstab.

You should also check your bootloader's boot options: if there is a root=/dev/sdb2 option, you should adjust that to match reality.

  • Thank you, Ihave already done some of the above steps, I will try fixing fstab and initramfs as you said. – drake01 Dec 11 '17 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.