1

I want to boot into graphical session on my Raspberry Pi 3 with Arch Linux ARM. I have installed xlogin (https://wiki.archlinux.org/index.php/Systemd/User#Automatic_login_into_Xorg_without_display_manager).

Content of ~/.xinitrc

#!/bin/bash

cd ~user
openbox >openbox.log 2>&1

When I run sudo systemctl start xlogin@user, in openbox.log is this:

Openbox-Message: Failed to open the display from the DISPLAY environment variable.

The exit code of openbox is 1. When I use openbox-session instead openbox, output is exactly the same. I tried to write $DISPLAY to file, it is :0 (so it is set).

Output of sudo systemctl status xlogin@user

* xlogin@user.service - Direct X login for user user
   Loaded: loaded (/usr/lib/systemd/system/xlogin@.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2017-12-09 21:19:55 UTC; 5min ago
  Process: 1355 ExecStart=/usr/bin/bash -l .xinitrc (code=exited, status=1/FAILURE)
 Main PID: 1355 (code=exited, status=1/FAILURE)

Dec 09 21:19:54 alarmpi systemd[1]: Started Direct X login for user user.
Dec 09 21:19:54 alarmpi systemd[1355]: pam_unix(login:session): session opened for user user by (uid=0)
Dec 09 21:19:55 alarmpi systemd[1]: xlogin@user.service: Main process exited, code=exited, status=1/FAILURE
Dec 09 21:19:55 alarmpi systemd[1]: xlogin@user.service: Failed with result 'exit-code'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.