I would like to build LxQt from sources on a Ubuntu xenial derivative system. I followed the oder as described on https://github.com/lxde/lxqt/wiki/Building-from-source and libqtxdg compiled and installed fine but the second piece lxqt-build-tools doesn't run through cmake. I've installed all the listed Ubuntu pre requisites but I get the following for the mentioned package:

$ cmake ../
-- The C compiler identification is GNU 5.4.0
-- The CXX compiler identification is GNU 5.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works          
-- Detecting CXX compiler ABI info                                
-- Detecting CXX compiler ABI info - done                         
-- Detecting CXX compile features                                 
-- Detecting CXX compile features - done                          
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1")  
-- Checking for module 'glib-2.0>=2.50'                           
CMake Error at /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:367 (message):                                                      
  A required package was not found                                
Call Stack (most recent call first):                              
  /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:532 (_pkg_check_modules_internal)
  CMakeLists.txt:17 (pkg_check_modules)

-- Configuring incomplete, errors occurred!
See also "/home/ron/src/lxqt/lxqt-build-tools/build/CMakeFiles/CMakeOutput.log".

and I can't tell what went wrong. The listed log file does not provide much information either.... How do I get past this?

  • Your glib is older than 2.50. I think this is more than enough information. Dec 9, 2017 at 15:07
  • @IporSircer but it says Checking for module 'glib-2.0>=2.50' hence I assume that anything inbetween 2.0 and 2.50 should be okay, am I misunderstanding this? I have glibc-2.0 installed
    – stdcerr
    Dec 9, 2017 at 15:58

1 Answer 1


Short answer: You need the package libglib2.0-dev with a version no less than 2.5 to work.

Long answer (see also the comments to the original post):

glib-2.0 is the name to refer the package in pkgconfig and other tools. glib-2.0 does not necessarily mean the version number is 2.0. Since you are compiling from source. It is very likely that what you really need is libglib2.0-dev with a version not less than 2.5. dev here means "development" and you may interpret it as "you'll need this if you want to build something yourself". You need a development package to do compilation. Keep this in mind when compiling from source in the future. It will save your time.

  • Yes, Xenial only has libglib2.0-dev version 2.48. Dec 9, 2017 at 16:38
  • I suggest you either build glib from source, or compromise and use a slightly lower version of LxQt which accepts 2.48. The second choice is much simpler, actually. Ubuntu does have 2.54, however. Dec 9, 2017 at 16:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .