2

I'm running Manjaro Linux on my HP Pavilion laptop (15-au014ng) and recently I'm experiencing an odd behaviour:
When the laptop is powered off it drains the battery quite a lot. I'm losing up to 40% battery over night.

However this problem does only occur when "letting linux shutdown the computer" (either via the start menu or via shutdown now in the console). If I kill my computer by holding down the power button the battery stays about the same over the same period.

I am currently using the 4.9.71-1 LTS kernel, though I barely can believe that this is a kernel issue as I haven't upgraded the kernel (if I remember correctly - Is there a way to double-check that?) and it used to work just fine. I am experiencing this issue only for about 1.5-2 months.

I thought it might be a bug of one of the installed packages and that it would be solved within the next updated but it doesn't appear to be that easy.

I found this article on the topic which suggested to add ethtool -s eth0 wol d to /etc/rc.local.shutdown which I did (though I replaced eth0 with eno1 as this is the name of my Ethernet connection according to ifconfig). However this didn't solve the problem.

I also checked the WOL setting using sudo ethtool eno1 and it showed me that WOL should be disabled anyway.

The only thing I noticed is that I get this message during boot as well as during the shutdown process:

Dez 08 17:25:43 workstation kernel: Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
Dez 08 17:25:43 workstation kernel: Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
Dez 08 17:25:43 workstation kernel: bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
Dez 08 17:25:43 workstation kernel: Bluetooth: hci0: Failed to load rtl_bt/rtl8723b_config.bin
Dez 08 17:25:43 workstation kernel: Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
Dez 08 17:25:43 workstation kernel: Bluetooth: hci0: rom_version status=0 version=1
Dez 08 17:25:43 workstation kernel: Bluetooth: cfg_sz 0, total size 22496

Though I'm not sure whether that has something to do with the actual problem.

Does anybody have an idea what the cause of this might be and (ideally) how to fix it?

EDIT:
It appears that I this question describes a very similar if not the same problem (though with a newer kernel).

EDIT2:
I'm not sure when exactly this problem started but I know that I install all updates that octopi will provide me so it is absolutely possible (actually pretty likely) that the problem occured with some of these updates.
I do know however (just discoverd it) that my kernel has in fact being graded up. I know that when I first installed Manjaro on my laptop it shipped with kernel 4.9.47-1. I'm going to search for a way to check when these kernel updates have been performed to see if there is any connection.

  • please, describe better your laptop since the product code you provided does not get anywhere and explain why the issue started 2 months ago: software upgrade? – mattia.b89 Dec 24 '17 at 14:03
3
+50

Presumably some part of your hardware fails to power down. Maybe a driver issue.

You've shown us some stuff about bluetooth, and you're already looking at ethernet. Maybe this isrelevant, but before looking into details of what those log messages mean, maybe you can confirm whether this is the problem. Do you have a hardware switch on your laptop to disable networking? IF so it probably disables both ethernet and bluetooth, and you could test whether engaging that switch before shutdown stops the battery drain.

It seems likely that your OS is currently failing to shut down the relevant device properly, so just scripting a device shutdown might not work. You might need to look at the drivers for the relevant device(s).

You say this is a recent issue. What happens if you run an older kernel, with older drivers. IF this works, try to identify exactly which kernel update introduced the problem, and then go through the changelog looking for driver updates that might have introduced the problem. Maybe there's a fix already, whether or not manjaro's kernel has pulled it in yet, and you could put in a bug report to Manjaro. Or maybe the bug still needs to be filed against the driver.

I'm not sure whether Manjaro automatically cleans up old kernels, but multiple kernel versions can be installed at once, and you can select the one you want from grub.

  • Sadly it seems that it indeed does clean up older kernel. But installing am older kernel is a good idea. Will definitely try that. Do you think there might be log containing some hint which device might have failed to power down? – Raven Dec 31 '17 at 10:52
  • I'll reward this answer with the bounty as there is no other one around (and I don't think there is a simple answer to this problem) – Raven Dec 31 '17 at 13:42
  • I've got an issue on my old Lenovo X220 which sounds like it's due to a timing issue in modern kernels where going into sleep mode doesn't result in the appropriate signal being sent to the processor to put it into low power mode prior to going into sleep. Given the age of the computer it's not clear that the necessary hardware specific support will ever get developed. – mc0e Aug 18 at 4:50
3

Alright as it turned out that whatever the bug was, it seems to be fixed in kernel version 4.14.9-2.

Upgrading to this kernel resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.