1

I use my ~/.Xresources file to configure URxvt, and after adding comments to the file, it seems to have caused xrdb to stop accepting the file.

I now get this:

xrdb: colon missing on line 3, ignoring line
xrdb: colon missing on line 5, ignoring line
xrdb: colon missing on line 7, ignoring line
xrdb: colon missing on line 9, ignoring line
xrdb: colon missing on line 11, ignoring line
xrdb: colon missing on line 13, ignoring line
xrdb: colon missing on line 14, ignoring line
xrdb: colon missing on line 16, ignoring line
xrdb: colon missing on line 18, ignoring line
xrdb: colon missing on line 20, ignoring line
xrdb: colon missing on line 22, ignoring line
xrdb: colon missing on line 24, ignoring line
xrdb: colon missing on line 26, ignoring line

What is odd is that those are not all comment lines. Some of them are, some of them are blank, some of them are actual configuration lines. It's also odd that it seems to cut off past a certain point, the file is 42 lines.

My ~/.Xresources file is as

! === URvxt Configuration Section ===:

    ! Turn off the scrollbar.
    URxvt*scrollBar:            true

    ! Set an external border of 4 pixels.
    URxvt*externalBorder:   4

    ! Make the pointer blink.
    URxvt*pointerBlink:     true

    ! Save as many lines as zsh.
    URxvt*saveLines:            100000

    ! Set font to Terminus
    URxvt*font:             xft:Terminus:size=10

    ! === URxvt Colorscheme Section ===

        ! Set the foreground (text) to pure white.
        URxvt.foreground:       #FFFFFF

        ! Set the background to a grey-black.
        URxvt.background:       #151515

        ! Color 0 - Primary Background
        URxvt.color0:           #151515

        ! Color 1 - Primary Foreground
        URxvt.color1:           #FFFFFF

        ! Color 2 - Secondary Background
        URxvt.color2:           #1F1F1F

        ! Color 3 - Secondary Foreground
        URvxt.color3:           #787878

    ! === END URxvt Colorscheme Section

! === END URvxt Configuration Section ===

Does anyone know why I would be getting these errors?

1

It looks like xrdb is expecting comments to always start with '!' in the first column.

The documentation is not totally clear on this: "If a line begins with ! (exclamation point), it is considered a comment, and the rest of the line is ignored"

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.