8

I am configuring a BeableBone Black running a Debian image from BeagleBone.org.

I can see that init (i.e. systemd) is listening on ports 1880 and 3000.

debian@beaglebone:~$ sudo netstat -taunp | grep LISTEN
tcp        0      0 0.0.0.0:53              0.0.0.0:*               LISTEN      978/dnsmasq         
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      852/sshd            
tcp6       0      0 :::53                   :::*                    LISTEN      978/dnsmasq         
tcp6       0      0 :::22                   :::*                    LISTEN      852/sshd            
tcp6       0      0 :::1880                 :::*                    LISTEN      1/init              
tcp6       0      0 :::3000                 :::*                    LISTEN      1/init              

Previously, init was also listening on port 80. I disabled that with these commands from https://stackoverflow.com/a/16570889 :

systemctl disable bonescript.service
systemctl disable bonescript.socket
systemctl disable bonescript-autorun.service

How can I get system to tell me which services are listening on ports 1880 and 3000?

10

Use systemctl list-sockets and look in the first column, labeled LISTEN for something ending in :3000 or :1880. Let us know what you find!

1
  • Thanks. Appears to be node-red.socket and cloud9.socket. – mpb Dec 7 '17 at 23:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.