1

[EDIT] SOLVED!

I uninstalled vmware-tools and I'm able to switch to the proper resolution without it reverting back to the HiDPI mode.

Preface:

  • Linux Mint 18.3
  • VMWare Player 14
  • MacOS HighSierra (as guest OS on vmware)
  • Latest Darwin VMTools installed
  • Native monitor resolution 1920x1080

Issue:

When changing the VM's window size, if it gets any bigger than 1024x768 the guest OS automatically switches to HiDPI resolution making everything comically LARGE on the desktop, leaving it somewhat unusable.

The screen settings in MacOS has the option for 1920x1080 but after selecting it, the resolution switches back to HiDPI mode at 960x540 (HiDpi).

What's been tried

I've tried changing some of the config settings for the VM through VMWare Player, but that seems to have no effect.

I've tried disabling the guest's HiDPI mode using:

sudo defaults write /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled -bool false


I'd like to use MacOS for running some design software i.e. Photoshop, Sketch, Illustrator, but I'd need to run it at full screen to take full advantage. Yes, I know about Gimp, Inkscape etc, but they just don't cut it for my tastes/workflows. That and I already own licenses for the Mac counterparts.

Please help with suggestions, tips, tricks etc. Much appreciated!

2

I tried going down the same route, but found that even when setting the value you modified, it would automatically reset:

defaults read /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled
1

After searching the internet, I came across this line (disabling auto-HiDPI for VMware):

defaults write ~/Library/Preferences/com.vmware.tools.plist enableAutoHiDPI -bool false

It didn't work immediately, but after a reboot I was able to set the resolution without it automatically changing to HiDPI:

cd /Library/Application Support/VMware Tools
./vmware-resolutionSet 1920 1080

Hope it works the same for you without un-installing VMware tools.

0

Here's what worked for me.

With the guest running, click Player->Manage->Virtual Machine Settings and then click display in the left column. Uncheck the box labeled "Automatically Adjust User interface size in the virtual machine".

The resolution will revert every power on, but you can now choose your display's native resolution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.