1

This is a bit of a strange problem, but I seem to be having issues with graphics drivers. I'm running :

Linux mint 18.1 Serena
Occurs across many kernels
Intel i7-6500U
nVidia GEforce gtx950m
16gb ram
128GB SSD and 1TB HDD

I'm getting lines across the screen, mostly when rendering PDF/documents (google docs, slack etc). I don't have issues with my text editor (sublime text 3), or ever in a terminal (putting a transparent terminal over the affected area fixes the issue as well). Watching videos is fine most of the time (youtube rarely has issues, netflix never).

I've tried the nvidia-381,384,387 drivers and a few nouveau drivers (they've updated at least once since this problem started occurring, and the update didn't fix it).

Interestingly, if I switch between two drivers, I have no issues while switching, once I restart and the new graphics driver is loaded, I have issues again.

I am perfectly happy with completely turning off the graphics card to save power, I never do anything requiring a GPU anyways (I'm on a laptop).

Are there ways to completely disable the GPU? Will graphics be rendered by the CPU (I'm thinking the generic VGA driver on windows)? I'm experienced with linux, however inexperienced with graphics drivers and configuring them.

Edit: I've done some more digging, and the problem is getting different. It appears I don't have an xorg.conf file. There are two files that are xorg.conf.[date], and they have the same contents:

Section "ServerLayout"
   Identifier "layout"
   Screen 0 "nvidia"
   Inactive "intel"
EndSection

Section "Device"
   Identifier "intel"
   Driver "modesetting"
   BusID "PCI:0@0:2:0"
   Option "AccelMethod" "None"
EndSection

Section "Screen"
   Identifier "intel"
   Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection

If I enable one of them, the graphics issue goes away. However, this restricts the resolutions that I can select for the monitor, and also changes my X login screen to a very basic one (this I can live with, I assume it's because xorg hasn't be loaded yet). Is there a way to get these resolution options back? I assume now that xorg is loading properly, it's reading from the display and only giving the resolutions it can display properly?

Even if I go to a resolution that does work, I still have the display issue.

  • 2 graphic cards? Is it a macbook? – Rui F Ribeiro Dec 7 '17 at 17:22
  • 1
    I only have one graphics card, the nVidia 950M. It's an ASUS harman/kardon – Brydon Gibson Dec 7 '17 at 17:23
  • You could try using the vesa driver, but... ick. – Ignacio Vazquez-Abrams Dec 7 '17 at 19:26
  • Also, Harman/Kardon is a speaker manufacturer, not the device model. – Ignacio Vazquez-Abrams Dec 7 '17 at 19:26
  • It's an asus UX510U, didn't realize that was just the speaker model, I had thought asus owned H/K – Brydon Gibson Dec 7 '17 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.