3

I've found several web pages that talk about how to set case sensitivity in searches in Kate. However, what I actually see on my screen doesn't match any of those pages. Here's a screen shot in which I'm using the the search and replace plugin:

enter image description here

And here's a screenshot of using just the built-in search:

enter image description here

Neither of those options look like they provide anywhere to set the case sensitivity of the search.

I'm using Kate version 16.12.3 with the KDE framework 5.31.0. Please let me know if there's any other info I should provide.

Any help on finding those options would be much appreciated.

3

The latest version is Kate 17.08.3. There's a switch to set case-sensitivity in the search dialog. You should update

  • I see. OK, I'll look into that. Unfortunately, I'm already using the latest version available by default through Ubuntu 17.04. Can you provide a suggestion on how to installed a later version of Kate than is available through those repositories? Thanks for the help. – tscheingeld Dec 7 '17 at 16:32
  • Even Ubuntu 17.10 only has Kate 17.04, so it looks like you're out of luck until the Ubuntu people update. Or ask on AskUbuntu askubuntu.com – PiedPiper Dec 7 '17 at 16:40
  • 2
    I just checked Kate 17.04 on a Ubuntu system. The case-sensitivity switch is there but not visible, because the icon seems to be missing. Try mousing over the Find line just to the right of the up/down arrows. – PiedPiper Dec 7 '17 at 16:49
  • Thank you! I posted a summary as an answer. Thanks for all your help today. – tscheingeld Dec 7 '17 at 20:10
  • Case button still invisible on v18.03.7 (Debian 9.3/Cinnamon) but at least it works. (BTW, v16.08. also works w/ invisible button for me.) – Elliptical view Mar 6 '18 at 18:15
2

So, with some great help from PiedPiper (thank you!) I found the answer to my question. The feature I wanted wasn't available in the version of Kate I was using. So I upgraded my entire system to Ubuntu 17.10 so I could get the latest Kate.

That version of Kate does have a case sensitivity button, but for some reason it's invisible. If you mouse over where it should be you'll get a little title box saying "Match Case". That's where the invisible button is sitting:

Screenshot showing that in version 17.04.3 the match case button is hidden but usable

So the feature is there, you just have to know where the invisible button is.

  • I found the missing icon. install unity-tweak-tool, run it and select Appearance/Icons/Oxygen. You need to have oxygen-icon-theme installed – PiedPiper Dec 8 '17 at 10:57
  • I installed unity-tweak-tool and oxygen-icon-theme. When I ran unity-tweak-tool at the command line I got this: – tscheingeld Dec 9 '17 at 21:49
0

I installed unity-tweak-tool and oxygen-icon-theme. When I ran unity-tweak-tool at the command line I got this:

terry@inspiron:~$ unity-tweak-tool

** (unity-tweak-tool:18598): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
/usr/lib/python3/dist-packages/UnityTweakTool/__init__.py:40: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
Error: schema com.canonical.notify-osd not installed
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

I tried to install com.canonical.notify-osd through Synaptic, which couldn't find any such package. At this point I've got what I need so I'll let this issue go, but thank you for the additional help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.