6

I'm running a lot of stuff using systemd's user-level service management. So far it's been great being able to take advantage of timers, conditional services, etc. but one thing that is sorely lacking is a persistent journal.

I'm on Ubuntu 16.04. I can see service status via systemctl --user status servicename.service, but I can't see any logs via journalctl:

$ journalctl --user
No journal files were found.
-- No entries --

Is there something that I need to do to get user-level journald support working?

2
  • Works fine here (Fedora 26). No idea how Ubuntu handles it. Dec 7, 2017 at 4:15
  • Does Fedora run a user journal in its own process? Not sure how the journal works in user mode. Dec 7, 2017 at 4:37

2 Answers 2

7

Two things:

  1. Ubuntu systemd journal entries are not persistent by default. Edit /etc/systemd/journald.conf and set Storage=persistent to fix that part.
  2. Unfortunately, on Ubuntu 16.04 with systemd 239 journalctl --user --unit= does not mean the same thing as journalctl --user-unit=. While the former may be more intuitive, the latter is likely what you want.
1
  • 1
    I answered a similar question here for Ubuntu 17.10 where setting Storage=persistent fixed the issue.
    – datu-puti
    Dec 21, 2017 at 18:06
1

I had not realized that the user I was trying to read logs from was a system user. Systemd directs logs of user services of system accounts to the system journal: https://wiki.archlinux.org/index.php/systemd/User#Reading_the_journal

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.