2

Linux is crashing (kernel panic?) and outputs this error on my screen. My system randomly freezes impredictably every hour or so, but this is the first time I've been seen this output. console output upon crash

Unfortunately I haven't been able to find much information about it online. What does it mean, and what do I do about it? I've already reinstalled my operating system - it hasn't helped.

I'm using a ThinkPad T430, 16 GB of RAM with Fedora 27 - Kernel: 4.13.16-302.

  • Can you find related infos in /var/log/messages, or where the syslogs are written to in Fedora? Or can you scroll up the screen (usually with [Shift] + [PgUp]) and add the missing kernel output from the moment the problem occurs? I already see a reference to pulseaudio in the partial trace above, but it's unclear if that's the source of your issue; however you may try disabling the pulseaudio sound server and everything related (meaning to kill the process and make sure it isn't started again) to verify. – Murphy Dec 6 '17 at 12:27
  • This seems to be related to your other question unix.stackexchange.com/questions/408484/… – Murphy Dec 6 '17 at 13:15
  • It is, that screen was just the output of running lspci and lsmod. The above is the first time I actually got part of the error from the kernel. – J.L.Louis Dec 6 '17 at 13:20
  • This feels like a memory fault. It would be worth trying one of the memtest boot tools – roaima Dec 6 '17 at 19:33
  • I ran memtest86+ on both modules individually, but the memtest test froze on both at the exact same time (like 3:26 or something), every single time. I ran the thinkpad onboard memory diagnostics, one initially failed, but after (physically) cleaning the module pins, it no longer occured. – J.L.Louis Dec 6 '17 at 22:49
1

Try with a live distribution and make a disk copy. The bug seems in EXT4 (so the filesystem), so any action you will do, it could make you to lose more data and files.

Check the hardware (e.g. with memtest). Once you rules out this, check if you have installed some modules outside your distribution. If you have no external module, make a bug to your distribution.

Unfortunately, your kernel is tainted (you used a non approved module, probably from your video card), so you cannot get full support from EXT4 maintainers (the bug seems in such subsystem), but you can try to remove such modules, and see if the bug come again (and so you can report it).

On EXT4 bugs there is not much you can do. You can eventually try a older version, or try to repair the filesystem (using a live distribution or a rescue "disk").

  • 1
    Sometimes a kernel is tainted due to a previous non fatal kernel error - not necessarily an unapproved module. Look and see if you can find the root cause of the taint, it could be related. – rrauenza Dec 7 '17 at 4:18
  • I recently did a clean install of the OS (because of that same error), that's should rule file system issues, right? – J.L.Louis Dec 10 '17 at 0:17
  • 1
    Yes (if you reformatted the disks). If problems continues, you should look: S.M.A.R.T. tools, to see if the harddisk is at end of life, memory problems (memtest86+), or you have a rogue hardware or rogue driver which corrupt memory. – Giacomo Catenazzi Dec 10 '17 at 13:42
1

I ended up fixing this problem by removing one of my memory modules. Either the SODIMM module or the port itself was defective (not sure since I haven't yet replaced it).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.