1

I am using Trisquel version 7 (Belenos), which is based on Ubuntu, with the LXDE desktop environment. It seems to be using the gnome-keyring-daemon to store and remember passwords; however, it doesn't seem to be working properly. For example, when I open Evolution mail, I am prompted for my e-mail/calendar/address book passwords, and then I am asked to give a password for a 'default keyring' to store them. However, the 'default keyring' doesn't seem to persist - I get asked the same questions again and again every time I start Evolution.

I read the man page for gnome-keyring-daemon, but it didn't to help a great deal in explaining how it works. Does anyone know what the problem might be?

Edit:

Just to add, I tried removing and then re-installing the gnome keyring package and the problem was still there. I will try doing a 'complete removal' and see if that helps, in case there are some broken config files hanging around.

1

I dug into this a bit more and the issue seems to be similar to the one in this question:

How do I fix "No such secret collection at path: /" for gnome-keyring and Arch Linux?

When I loaded up Seahorse and tried to create a new keyring, I got the exact same 'no such secret collection at path ..' error message. It seems the keyring info is supposed to be stored in the folder ~/.local/share/keyrings; however, in my case, this was actually a file instead of a folder, and just full of some useless junk. So, I renamed the file; created the keyrings folder with the correct permissions; and it seems to be working fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.