1

Running Ubuntu 16.04, mailman 2.1.24, postfix 3.1.0.

The server runs several domains. Postfix and virtual mailboxes are running well. After much wrestling I have mailman working with one list. I then imported a list, from the previous host, and used withlist to import it. I checked that the aliases were generated, reloaded postfix, and sent a test message, which generated an unknown user bounce.

This lead me to check by creating a new list and testing it. Same message.

The list address is translated to an @localhost, which I understand is normal, and the generated aliases include @localhost.

I'm not really sure how to move forward. Any thoughts?

Here's the output of postconf -n:

append_dot_mydomain = no
biff = no
content_filter = smtp-amavis:[127.0.0.1]:10024
default_destination_concurrency_limit = 1
default_destination_rate_delay = 5s
default_process_limit = 20
header_checks = regexp:/etc/postfix/header_checks
inet_interfaces = all
inet_protocols = ipv4
mailbox_size_limit = 0
mydestination = localhost
myhostname = domain.org
mynetworks = 127.0.0.0/8, <public ip>, <internal ip>
readme_directory = no
recipient_delimiter = +
relay_domains = mydestination, lists.virtualdomain.org
smtp_connect_timeout = 60s
smtp_destination_concurrency_limit = 1
smtp_destination_rate_delay = 5s
smtp_extra_recipient_limit = 10
smtp_host_lookup = dns, native
smtp_tls_note_starttls_offer = yes
smtp_tls_security_level = may
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_client_restrictions = permit_sasl_authenticated
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
smtpd_relay_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_path = private/auth
smtpd_sasl_type = dovecot
smtpd_sender_restrictions = reject_unknown_sender_domain
smtpd_tls_CAfile = /etc/ssl/certs/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/ssl/certs/smtpd.crt
smtpd_tls_key_file = /etc/ssl/private/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_security_level = may
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
spamassassin_destination_recipient_limit = 1
tls_random_source = dev:/dev/urandom
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual-alias-maps.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf
virtual_transport = lmtp:unix:private/dovecot-lmtp
postconf: warning: /etc/postfix/master.cf: unused parameter: local_recipent_maps=
0

For anyone that finds this while searching answers, the ultimate answer was found by slamming my head against things until I died.

I'm a mess and I don't necessarily recall everything I did, but I'm going to try.

I decided to follow the postfix-to-mailman.py route, since the Ubuntu documentation leans heavily that way.

I removed mydestination from relay_domains. I think that was a leftover from something else, or older documentation that I followed at some point. I also removed local_recipient_maps to get rid of that warning. That's been there a while, but felt I'd mention it.

The critical points, I think, were twofold:

The removal of the POSTFIX_STYLE_VIRTUAL_DOMAINS line. Reading other things I suspected that this was only relevant when using postfix as the MTA, and that appears to be correct since (so far) it's working.

Second, removing the relay_recipient_maps line. Again, postfix isn't handling these messages, mailman is.

I think that's about the sum of it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.